[OS X TeX] Re: LaTeXit 2.0 unusable

Erik Jensen ejensen at unbc.ca
Mon Nov 9 16:47:17 EST 2009

On 2009-11-09, at 1:13 PM, <epicurus at forallx.net>  
<epicurus at forallx.net> wrote:

>>> Just tried out LaTeXiT 2.0.0.  It won't typeset anything, and
>>> crashes shortly after a beach ball that occurs shortly after telling
>>> it to ``LaTeX it!''.  The Console says it's a segfault.  Anyone else
>>> having this problem?
>>> 10.5.8 Intel.  Previous version of LaTeXiT worked fine.
>> It's working fine here. You might try to remove the preference files,
>> fr.chachatelier.pierre.LaTeXiT.plist and fr.club.ktd.LaTeXiT.plist in
>> ~/Library/Preferences/ (~ is your HOME folder). You'll have to set up
>> any customizations you had before.
> Thanks, but that didn't work.  Still the beach ball, still the  
> crash.  What's more, after the crash my font caches seem to be  
> messed up: they show the same symptoms as came from the infamous  
> "font cache bug".  I patched the binaries affected by the fontcache  
> bug when the patches came out.  LaTeXiT is messing with the cache--- 
> is that even possible?

I found that LaTeXiT 2.0 worked fine on my office computer and MacBook  
(both running 10.6.1) but crashed as described on my Mac at home  
running 10.5.6. I rebooted my home Mac on 10.6.1 and it worked fine. I  
had done the Preferences file removal but that did not help things on  
the 10.5.6 system. i am wondering if there is an issue on pre-Snow  
Leopard systems. I also see some errors thrown up in the Console in  
10.5.6 but had not fully investigated yet so I have not emailed Pierre  
about it so far.


More information about the MacOSX-TeX mailing list