[OS X TeX] unable to use makebst

Herbert Schulz herbs at wideopenwest.com
Tue Aug 24 16:20:35 EDT 2010

On Aug 24, 2010, at 2:11 PM, Denis Chabot wrote:

> Hi,
> I need to create a new bst file and it has been a while since I used makebst. But do I have a hard time just launching it.
> When typing "latex makebst" in terminal, I get 
> -bash: latex: command not found
> I read the FAQ on <http://www.tug.org/mactex/2009/faq/>, in particular items QM.09 and QM.10.
> My installation is TeXLive 2009 from MacTeX, so according to QM.09 it should have worked. 
> Just in case, I followed the instructions in QM.10 for when TeXLive 2008 is installed but the computer is then upgraded to Snow Leopard. To no avail.
> I reinstalled TeXLive 2009 from a fresh copy of MacTeX, but I still get the same message from Terminal, even though LaTeX works fine under TeXShop.
> Can you suggest a way out?
> Thanks in advance,
> Denis Chabot


After you follow the instructions in QM.10 parts (d) and (e) you need to either open a new Terminal Window or restart Terminal for the fixed up PATH to take effect. Did you do that?

In Terminal (after above), what does

echo $PATH


The reason that GUI front ends still work is that they use /usr/texbin directly so they don't depend upon the existence of the correct PATH variable. There may be some TeXShop engines that won't work!

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list