[OS X TeX] Russian characters contained in included .pdf do not appear in compiled document

Alan Munn amunn at gmx.com
Mon Dec 20 07:40:25 EST 2010

On Dec 19, 2010, at 7:11 PM, Alan Munn wrote:

> On Dec 19, 2010, at 6:19 PM, Manuel wrote:
>> On 19/12/2010, at 23:52, Alan Munn wrote:
>>> Well we know what's happened now, but not why: the original  
>>> document has 6 fonts embedded in it; the file created by pdfpages  
>>> has 5.  The difference is that the original document has  
>>> CenturySchl-Bold embedded twice, but with different encodings: one  
>>> is Roman and the other is Custom.  I suspect that pdflatex itself  
>>> is 'cleaning up' the multiple embeddings incorrectly.  Here's a  
>>> solution:
>>> Process your file with xelatex instead of pdflatex; it doesn't  
>>> have this problem on my test document.  (There may be other  
>>> aspects of pdfpages that might not work with xelatex, but it won't  
>>> harm to try.)
>>> Alan
>> ...and: bang! - it worked. With XeLaTeX everything is fine again  
>> and my compiled document is as it should be. Thank you, Alan, and  
>> David, Claus, Alain, for your kind help.
> I'm glad it worked.  I've filed a bug report with the pdftex folk.

Apparently this is a known issue with pdf(la)tex, but it's not clear  
that it will be fixed, because it might break things and it's not  
clear what the correct behaviour should be.  The issue arises when the  
included pdf contains a different version of the font from the one on  
the  local system but with the same name.  pdf(la)tex uses the local  
version, which is then missing the glyphs.  There is a solution within  
pdf(la)tex is to tell it not to replace included pdf fonts, so you can  
continue to use pdflatex if you include the following command in your  



Alan Munn
amunn at gmx.com

More information about the MacOSX-TeX mailing list