[OS X TeX] otftotfm

Michael Sharpe msharpe at ucsd.edu
Tue Sep 21 13:41:28 EDT 2010

I just tried to use otfinst to make a package to use Adobe Garamond Premier Pro in latex, and ran into  a problem where the underlying otftotfm was unable to create a legal tfm file for some combinations in T1 encoding. (This was version 2.83, distributed with MacTeX 2010.) This seems to be a known problem, fixed in version 2.84. I tried to install lcdftools 2.84 from source, but was unable to induce it to make use of my kpathsea libraries, which I have installed in the standard locations relative to /usr/local/, but which date from 2006. Running configure produced a fatal error, and config.log contained the line

in /usr/local/lib/libkpathsea.a, missing required architecture x86_64 in file

I'd appreciate any suggestions about the correct flags to use here (CFLAGS='-archi386',LDFLAGS='-archi386' did not work), or a site to find more recent kpathsea libraries. (The link to ftp://ftp.tug.org/tex/texk.tar.gz in kpathsea.pdf from the 2010 distribution is not valid.)


More information about the MacOSX-TeX mailing list