[OS X TeX] Font Installation MacTeX-2012

ThomasSchl thomas.schloemer at uni-konstanz.de
Wed Aug 8 09:41:30 EDT 2012

I saw there are some people having trouble installing individual fonts into
the texlive package. I have similar problems but none of the previous posts
by H. Schulz (or his guide "TeXLive2012Changes") helped me.

My situation is the following:
- I am using pdflatex
- I want to use the  http://scripts.sil.org/gentium gentium fonts 
- I have converted the TTF versions of these fonts using 
the guide by K. Höppner  some five years ago
- I used the converted gentium fonts successfully with MacTeX-2009 to

After installing MacTeX-2012 the fonts (which were were installed
system-wide in /usr/local/texlive/texmf-local) ceased to work with a similar
error as given by other users:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+264/600 --dpi 864
mktexpk: don't know how to create bitmap font for fgbr8r.
mktexpk: perhaps fgbr8r is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: pdflatex (file fgbr8r): Font fgbr8r at 864 not found
 ==> Fatal error occurred, no output PDF file produced!

After I read the TeXLive2012Changes PDF by H. Schulz, I carefully checked
all the parameters he mentioned, but---somehow---the new system refused to
detect my font. I decided to completely remove all TeXLive files (rests of
2011 and 2012) and to start anew:

- I installed the complete MacTeX-2012 from scratch
- I called tlmgr update --self, then tlmgr update --all
- I copied my font step-by-step into /usr/local/texlive/texmf-local as
   cp *.fd ../texmf-local/tex/latex/gentium
   cp *.tfm ../texmf-local/fonts/tfm/public/gentium
   cp *.vf ../texmf-local/fonts/vf/public/gentium
   cp *.pfb ../texmf-local/fonts/type1/public/gentium
   cp gentium.map ../texlive/texmf-local/fonts/map
  (This last step differs from the original guide by K. Höppner because of
some hint (by, was it updmap?) in MacTeX-2010 or MacTeX-2011)
- I created a new file updmap.cfg in ../texmf-local/web2c with the line "Map
gentium.map" plus an additional blank line
- I called
  sudo -H mktexlsr
- I called
  sudo -H updmap-sys

After that, I tried to set one of my old documents that uses the font, but
the error message stays exactly the same. I then called
  sudo -H updmap --enable Map gentium.map
but nothing changes. I also tried
  sudo -H updmap --syncwithtrees
but, again, the error persists.

Do you guys have any idea on how to proceed from here? I can't see the
'error' I made. Do you think my old conversion of the gentium TTF font is a
potential cause for this problem? Again: the conversion has functioned as
desired up to MacTeX-2011.


Thomas S.

View this message in context: http://macosx-tex.576846.n2.nabble.com/Font-Installation-MacTeX-2012-tp7579823.html
Sent from the MacOSX-TeX mailing list archive at Nabble.com.

More information about the MacOSX-TeX mailing list