[OS X TeX] using MathTime fonts

Art Werschulz agw at comcast.net
Tue Aug 21 20:43:55 EDT 2012


On Aug 21, 2012, at 7:30 AM, Herbert Schulz <herbs at wideopenwest.com> wrote:

> On Aug 20, 2012, at 7:42 PM, Art Werschulz <agw at comcast.net> wrote:
>> ...
>> As root, I run
>> # updmap --disable belleek.map
>> # updmap --enable mt-yy.map
>> ...
> Howdy,
> I assume # is your prompt?


> Where did you put your files?

agw at home:~$ kpsewhich mt-yy.map

> What do you mean by ``As root''? Do you mean you have actuated the root account and are logged in as root or do you mean using `sudo`?

I did "sudo bash".

> You should NOT be using `sudo` with updmap since that will create map files owned by root in your HOME folder. Please go to <https://dl.dropbox.com/u/10932738/index.html> and download, expand and read the TeXLive2012Changes.pdf.zip file. You should also the same with the Eps-Tiff-Conversion2012.pdf.zip document (although there is a copy of this in /Applications/TeX too).

I'll check this out.

However the procedure I outlined is exactly what I did on our Linux systems at work, and the MathTime fonts are working fine there.

> You're enable line is wrong, if anything it should be closer to
> updmap --enable Map=mt-yy.map

I actually used the command as you typed it; I mistyped it into the email text (should've done a copy-n-paste).

> although I'm not at all sure you should be using updmap rather than updmap-sys.

I tried both, with the same effect.

Thanks for the pointer to the two PDF doc files; when I get a chance (maybe tomorrow), I'll try out their advice.

Art Werschulz (8-{)}   "Metaphors be with you."  -- bumper sticker
GCS/M (GAT): d? -p+ c++ l u+(-) e--- m* s n+ h f g+ w+ t++ r- y?
Internet: agw STRUDEL comcast.net

More information about the MacOSX-TeX mailing list