[OS X TeX] t1unmac on Lion

Michael Sharpe msharpe at ucsd.edu
Wed Jan 11 12:43:11 EST 2012

On Jan 11, 2012, at 8:51 AM, James Mingo wrote:

> I am trying to produce pfb versions of some old Frutiger
> fonts using texlive2011 and the tool t1unmac from t1utils.
> The font information in the Mac version is in a resource
> fork, hence the reason for the FrutiBla/rsrc part. This
> command has always worked for me in the past (i.e. before
> Lion). As you can see from below it no longer works because
> t1unmac thinks FrutiBla/rsrc is specifying a directory as
> opposed to a fork.
> jam[Mac Version] ls
> FrutiBla*    FrutiBol*    FrutiIta*    FrutiLigIta*  FrutiUltBla*
> FrutiBlaIta* FrutiBolIta* FrutiLig*    FrutiRom*     Frutiger*
> jam[Mac Version] t1unmac -r FrutiBla/rsrc pfrc8a.pfb
> t1unmac: FrutiBla/rsrc: Not a directory
> Am I doing something wrong or has something changed so that
> t1unmac doesn't work any more?
> Thanks,
> Jamie Mingo

Fondu also fails under Lion, with much the same error message. It seems to be necessary to convert each PostScript LWFN to macbinary format first. Eg,

macbinary encode AJenIta 

which will create AJenIta.hqx, and you can then run

t1unmac AJenIta.hqx ajenita.pfb

Another Lion issue--copying using the Finder can destroy resource forks.


More information about the MacOSX-TeX mailing list