[OS X TeX] Questions about figures

R Martinez rm.tech at mac.com
Wed Jan 18 03:57:29 EST 2012


I'm having a puzzling problem and hope the list can help.

I am writing a document using the article class (preamble below). I am using TeXShop 3.04 on a MacBook Pro using Lion. 

I have been working on the document for some time and everything worked well until now. By this I mean that the document always typesets correctly.

The problem started when I added an appendix (a subsubsection) containing three lines of text and 15 figures. (The entire document contains 37 figures, including 15 in the appendix). Originally, the appendix had 12 figures, all of which typeset without a hitch. Then I tried to add three more figures one at a time, typesetting immediately upon adding each figure. Everything was OK for the first two figures, but typesetting failed when I added the third figure. The problem is not with the third figure because typesetting was OK when I commented out the second figure and  left in the third. All the figures use the same set of commands, which is a standard figure environment. The following are the commands for the third figure.

  \caption{Zero  of $ \Psi(\sigma )$ for $ \psi_0 = 16$.}	\label{fig:zerospsi0eq16}

The console contains the message: "LaTeX error: Too many unprocessed floats," and lists the command  "\centering\includegraphics[scale=0.9]{zerospsi0eq16.pdf}" as the source of the error.
Does anyone know what is going on? I appreciate all comments and suggestions.

Thanks in advance,

Raul Martinez

Here is the preamble.



\usepackage{amsmath, amssymb,amsthm}



More information about the MacOSX-TeX mailing list