[OS X TeX] TeXLive 2012 cannot find local fonts

Herbert Schulz herbs at wideopenwest.com
Sun Jul 8 12:17:43 EDT 2012

On Jul 8, 2012, at 10:54 AM, Murray Eisenberg wrote:

> I've installed MacTeX2012. I'm running as a user with admin privileges.
> However, I cannot successfully process any documents that use my local fonts, installed in ~/Library/texmf.


Where, exactly, did you install the fonts?

> But I get errors like the following (for a lucida test document):
>  kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+294/600 --dpi
>  294 hlhr8r
>  gsftopk: fatal: map file `psfonts.map
>  ' not found.
>  mktexpk: don't know how to create bitmap font for hlhr8r.
>  mktexpk: perhaps hlhr8r is missing from the map file.
>  kpathsea: Appending font creation commands to missfont.log.
>  )
>  !pdfTeX error: /usr/texbin/pdflatex (file hlhr8r): Font hlhr8r at 294
>  not found
> I _do_ have the requisite updmap.cfg file in ~/Library/texmf/web2c, with entries such as:
>  Map lucida.map #localtexmf/dvips/lucida/lucida.map
>  Map mtpro2 #localtexmf/dvips/mtpro2/mtpro2.map

DON'T put in those #... ``comments'' they don't work. The file should only contain

Map lucida.map
Map mtpro2.map

(notice the .map for mtpro2.map).

> Per what I understand the instructions in "TeXLive2012Changes.pdf" (H. Schulz, 2012/06/11) to say, I did run
>  sudo updmap-sys
> and then, since I had not updated anything with the 2012 TeXLive Utility or set its preference to include "Automatically enable fonts in my home directory", I did also run:
>  updmap
> But that didn't seem to do anything because I get "Permission denied":
>   /usr/local/texlive/2011/bin/x86_64-darwin/updmap: mkdir(/Volumes
>   /MacHD/Users/murray/Library/texlive/2011/texmf-config/) failed,
>   goodbye: Permission denied
> So I next ran
>   sudo updmap

I specifically say DON'T run

sudo updmap

since that produces files in your HOME directory that are owned by root!

> and that created new map files but said it couldn't find the requisite map files, including lucida.map (precisely what was needed for the test lucida document) and asked whether I had run mktexlsr.
> So I tried to run mktexlsr, but I got a series of "no write permission" errors. So of course I then ran
>  sudo mktexlsr
> which updated /usr/local/texlive/2011/../texmf-local/ls-R....
> when that tries

Not needed for files in ~/Library/texmf.

> Still document would not compile. I tried again
>  sudo updmap
> but still no luck in compilation.
> What's wrong and how to fix?

1)Remove ~/Library/texlive/2012. You may need to use your admin password to do this since you used sudo before.

2)Where are your map files?

3)Fix up your updmap.cfg as stated above.

4)Simply run


in Terminal and note it's output.

If the fonts were installed properly that should do the job.

PS: If the Lucida fonts work but the MTPro2 fonts don't you may need to add the line

#! Map belleek.map

to your updmap.cfg file in ~/Library/texmf/web2c to disable the belleek.map file and then rerun


to rebuild your local system map.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list