[OS X TeX] Fonts in Mountain Lion

Michael Welsh yomcat at yomcat.geek.nz
Thu Jul 26 05:03:53 EDT 2012

On 26/07/2012, at 8:45 PM, Peter Dyballa <Peter_Dyballa at Web.DE> wrote:
> Am 26.07.2012 um 04:18 schrieb Michael Welsh:
>> mktexpk: don't know how to create bitmap font for rcomic7m.
>> mktexpk: perhaps rcomic7m is missing from the map file.
> Michael,
> this error means that pdfTeX hasn't found an entry for rcomic7m. It's not that ComicSans has become unusable. Then the failure would have been different. And would have occurred later.

I should have known that. I blame the update to ML and lots of things all breaking at once
> You're using now TeX Live 2012. Here updmap/updmap-sys work a bit different than before (also due to sudo/sudo -H). When your additional MAP file fragments are in your private tree you now need to run updmap privately (meaning: no sudo!) – because sudo -H masks your private tree when used from TLU or tlmgr – so that your private pdftex.map file is finally created.
I ran updmap (as me), and it ran fine, but still no luck. updmap-sys had a cry:
Jaina:~ yomcat$ updmap-sys
updmap is using the following updmap.cfg files (in precedence order):
updmap: Directory "/usr/local/texlive/2012/texmf-var/fonts/map/dvips/updmap" isn't writable:  at /usr/texbin/updmap line 1206.

The fonts are installed in /usr/local/texlive/texmf-local. That's not my tree, is it?
The file rcomic7m.tfm is in ./fonts/tfm/microsoft/comicsans

> When you still have TL '11 on your Mac, try for comparison/verification to switch that version active and see how it works with your TeX file!

Unfortunately, I deleted it this afternoon while trying to get MySQL working again (I was in the neighbourhood).

More information about the MacOSX-TeX mailing list