[OS X TeX] Fonts in Mountain Lion

Herbert Schulz herbs at wideopenwest.com
Thu Jul 26 08:55:55 EDT 2012

On Jul 26, 2012, at 4:03 AM, Michael Welsh wrote:

> On 26/07/2012, at 8:45 PM, Peter Dyballa <Peter_Dyballa at Web.DE> wrote:
>> Am 26.07.2012 um 04:18 schrieb Michael Welsh:
>>> mktexpk: don't know how to create bitmap font for rcomic7m.
>>> mktexpk: perhaps rcomic7m is missing from the map file.
>> Michael,
>> this error means that pdfTeX hasn't found an entry for rcomic7m. It's not that ComicSans has become unusable. Then the failure would have been different. And would have occurred later.
> I should have known that. I blame the update to ML and lots of things all breaking at once
>> You're using now TeX Live 2012. Here updmap/updmap-sys work a bit different than before (also due to sudo/sudo -H). When your additional MAP file fragments are in your private tree you now need to run updmap privately (meaning: no sudo!) – because sudo -H masks your private tree when used from TLU or tlmgr – so that your private pdftex.map file is finally created.
> I ran updmap (as me), and it ran fine, but still no luck. updmap-sys had a cry:
> Jaina:~ yomcat$ updmap-sys
> updmap is using the following updmap.cfg files (in precedence order):
>  /usr/local/texlive/2012/texmf/web2c/updmap.cfg
>  /usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg
> updmap: Directory "/usr/local/texlive/2012/texmf-var/fonts/map/dvips/updmap" isn't writable:  at /usr/texbin/updmap line 1206.
> The fonts are installed in /usr/local/texlive/texmf-local. That's not my tree, is it?
> The file rcomic7m.tfm is in ./fonts/tfm/microsoft/comicsans
>> When you still have TL '11 on your Mac, try for comparison/verification to switch that version active and see how it works with your TeX file!
> Unfortunately, I deleted it this afternoon while trying to get MySQL working again (I was in the neighbourhood).


Please download the TeXLive2012Changes document document from <https://dl.dropbox.com/u/10932738/index.html>. It gives instructions for how to deal with font installations under TeX Live 2012.

Where did you install the comicsans font and map file? It sounds like you tried to run 


when you should have run

sudo -H updmap-sys

if you installed it in the texmf-local tree. If you installed it in your personal tree (starting at ~/Library/texmf) you must run


and NOT

sudo updmap

since that will create a folder owned by root. If you ever ran 

sudo updmap

you will need to delete ~/Library/texlive (note: yes, texlive not texmf) using your admin password and start over.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list