[OS X TeX] PATH mystery

Michael Sharpe msharpe at ucsd.edu
Fri Aug 2 21:09:47 EDT 2013

After cleaning up some setup files on my machine, I ran across the following oddity, which I am unable to understand.

I had removed /usr/texbin from PATH in ~/.profile and made it an entry in /private/etc/paths. After a restart, echo ${PATH} showed it was in the path, and I could run things like kpsewhich from the command line without problems. However, when I tried to run autoinst and otftotfm, I experienced continual errors. For example,

autoinst --target=./texmf ...


Unknown option: target


/usr/texbin/autoinst --target=./texmf ...

did not complain. Likewise,

otftotfm -e fontools_ly1 ...


otftotfm: encoding 'fontools_ly1' not found


/usr/texbin/otftotfm -e fontools_ly1 ...

worked as expected. All these problems vanished after I returned /usr/texbin to PATH in ~./profile. It would appear that /private/etc/paths (and /private/etc/paths.d) processed by path_helper do not make PATH elements with the same status as those set directly in a bash initialization file. Can anyone shed light on this?


More information about the MacOSX-TeX mailing list