[OS X TeX] Synctex doesn't work with file names that have spaces. Is this fixable?

Vamos, Peter P.Vamos at exeter.ac.uk
Fri May 10 14:23:54 EDT 2013

On 9 May 2013, at 20:08, mrl wrote:

> Because of the demise of Textures

Is Textures no more then? Is Barry Smith still around? Just tried Blue Sky Research website, it doesn't work. If it is indeed dead, someone should write an obituary.

I have many fond and not so fond memories of Textures. Started using it when it wasn't even called Textures and was marketed by the publisher Addison-Wesley.  Anyway, what is vaguely relevant here relates to

> This person has hundreds of files, that have spaces in their filenames.

Could this person be using plain TeX? Classic Mac OS always allowed spaces in file names, unlike Win of yore, or Unix, and so did Textures, but for Plain TeX only! 

This is in fact one of my not so fond memories. I was a very late convert to LaTeX. When I did move over to LaTeX I tried it first by converting one of my plain TeX files, still using Textures. It didn't work. Didn't typeset. I spent a very long and frustrating  time trying figure out why. Inspect code. Re-read the Textures manual. LaTeX by Lamport. Alas, this list didn't exist in those days. You could email or maybe phone  Blue Sky but I was  in the morning in Europe and they in Oregon. Eventually I figured out that my file name had a space in  it; maybe I did have an error message "no aux file", I can't remember. Once I deleted the space, LaTeX on Textures worked. I must have, eventually, guessed that at the core the (La)TeX used by Blue Sky was still C+ or something like that and LaTeX needed to write and then call the aux file and this mechanism was not made Mac friendly.

Very soon after this episode I abandoned Classic OS, Plain TeX and Textures for OS X, LaTeX and TexShop. May be later incarnations of Textures allowed spaces in file names even in LaTeX, I don't know. 

So what is in a filename? I was reminded of the above recently when opening one of my old (Plain TeX) Textures files in TexShop to find the Typeset button greyed out and the Program button showing ConTeXt. After chaging this to Plain TeX the Typeset button was still greyed out. No spaces in the file name but there was a dot '.'.  Classic OS could deal with such a file name, not OS X and TexShop. So the right question is: What should not be in a file name? Dick Koch wisely counsels against using spacers. I would add to this any character which is used in a path name in some system (Mac, Win, *nix) such as \  / . :  etc.


PS To the OP: 

> This person has hundreds of files, that have spaces in their filenames.

There are a number of batch change file name utilities around, I would assume that some of these could be used to rename  the files e.g. replace spaces with an underscore _.

More information about the MacOSX-TeX mailing list