[OS X TeX] Yosemite install broke LaTeXiT (and Ghostscript)

Richard Koch koch at math.uoregon.edu
Wed Sep 17 18:22:30 EDT 2014


Thanks for reporting this. People have written me privately as well.

The problem is simple. Apple used to supply X11 with it's system, but no longer does.
Instead, the open source authors now supply it directly, and therefore can provide
more timely updates.

There are two versions of the Ghostscript binaries, gs-X11 and gs-noX11. When
MacTeX installs Ghostscript, it creates a symbolic link from the appropriate binary
to gs in /usr/local/bin, depending on whether you have X11 or not.

But when you upgrade the system, Apple removes X11, expecting you to get the
latest version.

There are two possible fixes. Either

	a) Create a new symbolic link in /usr/local/bin, named gs and pointing to


	b) Install X11, obtaining it from


Dick Koch

On Sep 17, 2014, at 2:53 PM, Gary L. Gray <euler at psu.edu> wrote:

> Hi All,
> Earlier this week, after some testing on an external drive, I installed Yosemite DP8 on my main machine. Shortly after doing so, I needed to do something in LaTeXiT and I got the following message when I launched it
> ghostscript not found or does not work as expected
> The current configuration of LaTeXiT requires ghostscript to work.
> Since LaTeXiT worked prior to the Yosemite install, I figured that Yosemite was the culprit. I tried running FixMacTeX2014.pkg and that didn't fix it. So, I went into /usr/local/bin and found the following
> lrwxr-xr-x   1 root  wheel        21 May 25 11:01 gs -> /usr/local/bin/gs-X11
> -rwxrwxr-x   1 root  wheel  33656924 Nov 26  2013 gs-X11
> -rwxrwxr-x   1 root  wheel  33521280 Nov 26  2013 gs-noX11
> gs was pointing to gs-X11 rather than gs-noX11 as I expected. I expect I could have fixed this easily in the Terminal, but I decided to grab MacTeX 2014 that I had on a thumb drive and reinstall Ghostscript to see if that fixed it. Sure enough, after doing so, I now see this
> lrwxr-xr-x   1 root  wheel        23 Sep 17 17:38 gs -> /usr/local/bin/gs-noX11
> -rwxrwxr-x   1 root  wheel  33656924 Nov 26  2013 gs-X11
> -rwxrwxr-x   1 root  wheel  33521280 Nov 26  2013 gs-noX11
> and LaTeXiT works fine again. I hope this helps someone if the issue comes up again as people install Yosemite in the coming weeks.
> Gary
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: http://email.esm.psu.edu/mac-tex/
> List Archive: http://tug.org/pipermail/macostex-archives/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the MacOSX-TeX mailing list