[OS X TeX] Can't find required tool

Richard Koch koch at uoregon.edu
Tue Aug 30 23:05:00 EDT 2016

First, your system is incredibly old. A G5 Mac could surely run Leopard, but you are still running
Tiger, which we haven't supported for God knows when.

Why not approach the situation scientifically. The error message says "/usr/texbin/pdflatex does not exist." So first try to see if that is true, by running Terminal, and seeing is


has an element named texbin, and then if this /usr/texbin is a link, and if so, where it points, and does that location contain pdtex.
If not, do you even have TeX on the system. If so, you could reconfigure TeXShop to look for typesetting tools in the exact location
of TeX.

This will require a knowledge of Unix, which you really need if you intend to stick with such an old system. I think you could update
to Leopard, and then you'd be on a system we support and 
> On Aug 30, 2016, at 7:57 PM, Richard J Benish <rjbenish at comcast.net> wrote:
> Greetings,
> On a G5 with Mac OS 10.4.11, I've been using TeXShop v 2.33 for years. Without consciously having changed anything to affect the program, suddenly, when I hit the typeset button I get the error message:
> "Can't find required tool.
> "/usr/texbin/pdflatex does not exist. Perhaps TeXLive was not installed or was removed during a system upgrade. If so, go to the TeXShop web site and follow the instructions to (re)install TeXLive. Another possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the fink teTeX distribution."
> I've tried restarting, correcting permissions, and reinstalling. After failing to find an old install version on the web, I tried installing from a locally saved copy of:
> MacTeX-2011.mpkg
> This resulted in a grayed out list of components which, when I clicked on INSTALL, resulted in an error saying "There is nothing to Install." Could that be because the non-functioning version needs to be uninstalled first? If so I hesitate to do so before getting confirmation.
> I've haven't found anything on the web to get me back to a properly functioning application.
> Any ideas?
> Thanks.
> Richard Benish
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq <http://www.tex.ac.uk/faq>
> List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/ <https://www.esm.psu.edu/~gray/tex/>
> List Archives: http://dir.gmane.org/gmane.comp.tex.macosx <http://dir.gmane.org/gmane.comp.tex.macosx>
>                https://email.esm.psu.edu/pipermail/macosx-tex/ <https://email.esm.psu.edu/pipermail/macosx-tex/>
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/ <http://mactex-wiki.tug.org/>
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex <https://email.esm.psu.edu/mailman/listinfo/macosx-tex>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-tex/attachments/20160830/47fd4c4c/attachment.html>

More information about the MacOSX-TeX mailing list