[OS X TeX] Mactex and PowerPC processors

Richard Koch koch at uoregon.edu
Mon May 2 14:05:04 EDT 2016

Tom and others on the mailing list,

> On May 2, 2016, at 10:04 AM, tkiffe <tkiffe at math.tamu.edu> wrote:
> I tried running the pretest version of mactex 2016 on an iMac with a PowerPC processor with OS X 10.5.6. Dvips crashed immediately with a segmentation fault and xdvi immediately quit, complaining that the libX11 library did not have the appropriate code. I didn’t do any further testing with mactex 2016 but I did go back to previous versions of mactex and had the same crashes with the 2013, 2014, and 2015 mactex distributions. I didn’t go back further than 2013.
> There were no problems with the pretest 2016 on an iMac with an intel processor running 10.5.6.
> Out of curiosity I tried building the 2015 texlive binaries from the texlive sources on the PowerPC iMac and immediately ran into serious compilation errors with the gmp library, xetex, etc.Perhaps it is time to drop support for PowerPC processors. I think the last Macs with PowerPC processors were built in 2006
> or 2007
> Tom
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
> List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
>                https://email.esm.psu.edu/pipermail/macosx-tex/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

This is an extremely interesting report.

With some trepidation, I decided to test myself. First I tested MacTeX-2016 on
Leopard Intel. I’m happy to report that pdflatex, dvips, and xdvi all worked fine.
Currently tlmgr doesn’t work from the command line, but that situation is
in flux and I’ll wait until tomorrow’s updates, and then report to Norbert Preining
if there are still problems.

Then I fired up the PPC machine where I make the binaries. It is a PPC Leopard
machine. Out of laziness,
I installed BasicTeX-2016 and Ghostscript 9.19 rather than the full MacTeX.

Both pdflatex and dvips worked fine. I also tried xdvi. It could correctly display
a 200 page dvi document. The only problem was that xdvi couldn’t communicate
with Ghostscript, so illustrations were replaced by blank squares.


Please note Tom’s very different experience. Why? I believe the reason is
that Tom updated X11, whereas I used the version of X11 that was running when
I was actually using these machines. On Leopard Intel, my X11 was created
on 9/23/07.

Since I actually compile using this X11, it is probably not surprising that it still


This experience reveals a potential problem. When an operating system
becomes obsolete, Apple provides updates for essentially one year, and
then the updates stop. Thus we compile the TeX binaries on very old system
software, and they will also run on very old system software.

But Apple no longer directly supplies X11, so we cannot be nearly as confident
that the X11 we used to compile will be the X11 the user uses to run the system.
It is lucky that this  problem hasn’t raised its head before. The really tricky case is
the current system. We compile 64 bit binaries on Snow Leopard, using
the version of X11 current at that time. Luckily, these binaries still work
on El Capitan. 


I’m going to claim that I compiled for Leopard PPC in the correct way, using its
original X11. On the other hand, the time is clearly coming to drop support for
PPC, and we’ll drop it next year unless there is powerful opposition.

Thanks to Tom for a very interesting report.

Dick Koch

More information about the MacOSX-TeX mailing list