[OS X TeX] TeXShop encoding issue

Sangwine, Stephen J sjs at essex.ac.uk
Fri Dec 8 13:13:05 EST 2017


I don’t think the 6, 9, 66, and 99 quotation marks are present in Latin 9. You can
check here: https://en.wikipedia.org/wiki/ISO/IEC_8859-15

A better solution would be to use UTF-8.

When checking encoding issues, I find it invaluable to use BBEdit (free demo version)
as it can open a text file with various encodings and line endings.

Le 8 déc. 2017 à 17:38, Rowland McDonnell <rowland.mcdonnell at physics.org<mailto:rowland.mcdonnell at physics.org>> a écrit :


I've just tried to use:


to allow me to use `native' non-ASCII characters in my input documents and the results have not been as expected.

I'm using TeXShop 3.92 and macOS High Sierra v10.13.1 (17B1003)

The TeXShop Source preferences pane lists "Encoding" as Western (ISO Latin 9).

When I process the following file with LaTeX:


“ ”  ‘ ’


the output pdf file contains four question marks where the quotation marks should be:

? ? ? ?

Note: I created the test file from scratch using TeXShop's File->New command.

On the off chance it might help, I tried:


“ ”  ‘ ’


and got the same results.

I closed the file and opened it again.  The quotation marks in the input file had all been turned into question marks.  The document text which had looked like this:


“ ”  ‘ ’


Now looked like this:


? ? ? ?


When I LaTeXed that file, I got question marks in the output file.

I changed the input file to:

% !TEX encoding = IsoLatin9

“ ”  ‘ ’


LaTeXing this file produced question marks in the output instead of quotation marks.

I saved this file, closed it, and reopened it in TeXShop and the input file again had the quotation marks replaced by question marks.

I assumed some kind of an encoding problem had occurred, deleted the question marks, and replaced it with:


“ ” ‘ ’


Processing that text using LaTeX produced an output of four question marks (and a page number) as before.

I closed the file and opened it again in TeXShop, to find that once again the quotation marks I'd entered had been turned into question marks:

? ? ? ?

TeXShop's Typesetting preferences are set to:

Dafault Command: LaTeX

Default Script: Pdftex

It appears something is not working properly.  I'd appreciate any insights into this issue.


P.S.  A typical console log from one of my tests looks like this:

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) (preloaded format=pdflatex)
restricted \write18 enabled.
entering extended mode
(./file encodings test 1.tex
LaTeX2e <2017-04-15>
Babel <3.10> and hyphenation patterns for 84 language(s) loaded.
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(./file encodings test 1.aux) [1{/usr/local/texlive/2017/texmf-var/fonts/map/pd
ftex/updmap/pdftex.map}] (./file encodings test 1.aux) ){/usr/local/texlive/201
Output written on "file encodings test 1.pdf" (1 page, 10010 bytes).
SyncTeX written on "file encodings test 1.synctex.gz"
Transcript written on "file encodings test 1.log".

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-tex/attachments/20171208/ae487a97/attachment.html>

More information about the MacOSX-TeX mailing list