[OS X TeX] "file not found"

Herbert Schulz herbs at wideopenwest.com
Thu Aug 9 08:15:54 EDT 2018

> On Aug 8, 2018, at 10:39 PM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:
> I am running into a confounding problem.  I wanted to build a source file for a paper by inputting separate sections into a master file (ie, in masterfile.tex, have a line “\input{section}”, and creating separately a file 
> section.tex).
> I think I have done this successfully before.  This time, the first input worked.  Then I tried to input into the section the contents of a file subsection.tex, in the same way—that is, via a command “\input{subsection}”.  (Note that all three are in the same folder).
> I got an error “ Latex error: can’t find file subsection.tex”.
> So I tried instead, in masterfile.tex, to follow the first command \input{section} with a second command \input{subsection}.  Same error message.
> The file names I initially worked with are different, but that is the essence of the problem.
> So I tried to create a “minimal example”.  Here are two files, sitting in the same folder:
> l
> InputTest has just a standard latex template, followed by “\input{first section}”.
> Trying to compile this, I get the error message “can’t find file first section.tex”.  (that is, this time even the first input doesn’t work)  Here is the log file:
> Zbigniew Nitecki
> Department of Mathematics
> Tufts University
> Medford, MA 02155
> telephones:
> Office    (617)627-3843
> Dept.    (617)627-3234
> Dept. fax    (617)627-3966
> http://www.tufts.edu/~znitecki/
> <first section.tex><InputTest.tex><InputTest.log>----------- Please Consult 


Best practice is to never use spaces in file names. If I remove the space in the file's name and also in the corresponding \input command it works fine.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list