[OS X TeX] TeXShop tilde not behaving

Richard Koch koch at uoregon.edu
Thu Feb 15 01:17:13 EST 2018

This problem is (probably) caused by Apple, not TeXShop, but you can turn it off. Go to TeXShop's Edit Menu, find the "Substitutions Menu",
and notice that you can select

	Smart Copy/Paste
	Smart Quotes
	Smart Dashes
Etc. These items are present not because I think users will want to turn them on, but instead because Apple often turns them on
automatically and I think users will want to turn them off.

If you use TeXShop's Key Bindings facility, you might also add strange tilde's in that way. By default, Key Bindings are off in
TeXShop because I dislike editors that modify what I type.

Dick Koch

> On Feb 14, 2018, at 7:25 PM, Alan Litchfield <alan at alphabyte.co.nz> wrote:
> Hi,
> Odd behaviour has appeared in TeXShop (or with OS X 10.13.3) in which the tilde no longer seems to provide a non-breaking space. Instead, I got a ? in the PDF output and the tilde in the source was changed to ? after running LaTeX. Then I changed the input in TeXShop to UTF8 and the ? changed to ËIJ, so I added \usepackage[utf8]{inputenc}. Then I got the tilde, ˜, instead of a non-breaking space :/
> Minimal example and output attached.
> Is there some setting I need to change? What am I doing wrong here?
> Thanks
> Alan
> --
> Dr Alan Litchfield
> AlphaByte
> PO Box 1941
> Auckland, New Zealand 1140
> <me.pdf>
> <me.tex>
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
> List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
>                https://email.esm.psu.edu/pipermail/macosx-tex/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the MacOSX-TeX mailing list