[OS X TeX] TeXShop in MacTeX 2018 pretest

Michael Sharpe msharpe at ucsd.edu
Fri Mar 16 17:19:03 EDT 2018

One more data point.

I installed mactex-20180304 on an old laptop (early 2008) running El Capitan. It seemed to install without issues. When I tried to start TeXShop (3.98), the program failed almost immediately and put up a Problem Report for TeXShop in which the most important line seemed to be

EXC_CRASH (Code Signature Invalid)

I did not try disabling SIP to check if that affected anything.

Replacing TeXShop 3.98 with 3.99 resolved the issue.


> On Mar 16, 2018, at 1:18 PM, Richard Koch <koch at uoregon.edu> wrote:
> John,
> Thanks very much for this test, which is actually good news for me,
> Another user installed also on El Capitan and reported that pdftex
> and other TeX binaries failed with an "illegal instruction 4" error.
> On my El Capitan machine, the binaries work, and indeed they are
> compiled on this machine.
> My machine runs 10.11.6, as does yours. I don't yet know what version
> of El Capitan this user is running.
> NOTICE TO OTHERS: We desperately need more tests on El Capitan!!!
> --------------
> Now as to your particular issue, I don't know if TeXShop 3.98 runs on
> El Capitan, but in the process or studying the issue above, I found that
> version 3.99 runs fine. The release version of MacTeX-2018 will contain
> 3.99, and indeed it already does here. So you did the correct thing by
> downloading the most recent TeXShop when the other one failed.
> Dick Koch
>> On Mar 16, 2018, at 1:06 PM, John Collins <jcc8 at psu.edu> wrote:
>> I've newly installed MacTeX 2018 pretest.  That went extremely smoothly, and the TeXLive 2018 pretest part of it seems to be working correctly.
>> However TeXShop.app as installed from the 2018 pretest crashes immediately on startup, with the message "TeXShop quit unexpectedly". If I start the executable (in Contents/MacOS) from the command line, it simply gives a message "Killed" and then stops. Info.plist reports the TeXShop version as 3.98
>> I restored an older version of TeXShop (3.77) from backup; that still worked.  Then I installed the newest version (3.99) from the Check for Updates menu item.  The new version works.
>> So there appears to be a problem specifically with the version of TeXShop that is is installed by the current MacTeX 2018 pretest (mactex-20180304.pkg).  I can provide the crash report if needed.
>> I am running El Capitan (10.11.6) on an iMac from mid 2010.
>> John Collins

More information about the MacOSX-TeX mailing list