[OS X TeX] TexShop macro problems on Mojave

Herbert Schulz herbs at wideopenwest.com
Tue Nov 20 11:02:42 EST 2018

> On Nov 20, 2018, at 9:45 AM, M. Tamer Özsu <ozsut at mac.com> wrote:
> I have done a clean install of MacTeX and TeXShop on a new machine running Mojave. Everything is updated to its latest version (TeXShop 4.16). I am having problems with the macros:
> - I tried OpenSelection (Cmd-opt-o) and nothing happens — The Macros menu title flashes, but that is it.
> - I tried the Insert Reference (Shift-cmd-R) and I get the message "TexShop Applescript error Not authorized to send Apple events to Finder” — for this I went to the Privacy tab on System Preferences and added TeXShop for full disk access as was suggested on some web site, but that did not do the trick.
> - I tried Insert Index and that worked.
> Any reason why some are not working? I appreciate any advice.
> Thanks.
> ==Tamer


Mojave introduced extra security for executing AppleScript, etc. Were you asked for permission to use Finder and/or System Events.app when you first ran the macros? If so, what did you respond?

Take a look at the Automation item under the Privacy Tab of System Preferences->Security & Privacy. TeXShop.app should appear there with one or more checked items  under it (e.g., System Events.app and/or Finder). Does TeXShop.app appear there? If so, are there items under it that have check boxes? If so, are they checked?

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list