<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Many thanks, Herb! Running Mountain Cache Cleaner twice with the settings that you indicated restored the icons. Great utility.<div><br></div><div>All best, Alan</div><div><br><div><div>On 19 Sep 2013, at 4:19 PM, 09/19/13, Herbert Schulz <<a href="mailto:herbs@wideopenwest.com">herbs@wideopenwest.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><meta http-equiv="Content-Type" content="text/html charset=windows-1252"><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><br><div><div>On Sep 19, 2013, at 3:18 PM, Herbert Schulz <<a href="mailto:herbs@wideopenwest.com">herbs@wideopenwest.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><br>On Sep 19, 2013, at 7:10 AM, Alan C. Bowen <<a href="mailto:bowen@IRCPS.org">bowen@IRCPS.org</a>> wrote:<br><br><blockquote type="cite">I am not sure that my original message got through, so I am resending this. Please excuse any duplication.<br><br><br><br>On updating to Mac OS 10.8.5, the TeXShop file icons all indicated and opened TextWrangler. I was able to set the files so that they all open TeXSHop. But now the file icons are either generic or those for exec files.<br><br>How do I fix this?<br><br>Alan<br><br></blockquote><br>Howdy,<br><br>Good old LaunchServices database... :-(<br><br>I use Mountain Lion Cache Cleaner, <<a href="http://www.northernsoftworks.com/mountainlioncachecleaner.html">http://www.northernsoftworks.com/mountainlioncachecleaner.html</a>>, set up as in the enclosed graphic and restart. Give the system a little bit of time to rebuild the database after the reboot and open TeXShop and create a dummy document and save it; it should have the correct icon.<br><br>You can also try to do a Safe Boot (Hold down the Shift Key when you start up the computer) until you get a screen with the progress bar. The login screen should say Safe Boot. Login, let the computer sit a bit to make sure all the databases are rebuild and the restart normally.<br><br>There have been a few times when I've had to do this more than once.<br><br>Good Luck,<br><br>Herb Schulz<br>(herbs at wideopenwest dot com)<br></blockquote><br></div><div>Howdy,</div><div><br></div><div>Sigh... forgot to attach the graphic:</div><div><br></div><div><span><Mountain Lion Cache CleanerScreenSnapz001.png></span></div><br><div>Good Luck,<br><br>Herb Schulz<br>(herbs at wideopenwest dot com)<br><br><br></div><br></div><br>----------- Please Consult the Following Before Posting -----------<br>TeX FAQ: <a href="http://www.tex.ac.uk/faq">http://www.tex.ac.uk/faq</a><br>List Reminders and Etiquette: <a href="http://email.esm.psu.edu/mac-tex/">http://email.esm.psu.edu/mac-tex/</a><br>List Archive: <a href="http://tug.org/pipermail/macostex-archives/">http://tug.org/pipermail/macostex-archives/</a><br>TeX on Mac OS X Website: <a href="http://mactex-wiki.tug.org/">http://mactex-wiki.tug.org/</a><br>List Info: <a href="https://email.esm.psu.edu/mailman/listinfo/macosx-tex">https://email.esm.psu.edu/mailman/listinfo/macosx-tex</a><br></blockquote></div><br></div></body></html>