<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><br><div><div>On Jul 8, 2014, at 2:03 PM, Victor Ivrii <<a href="mailto:vivrii@gmail.com">vivrii@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Jul 8, 2014 at 12:35 PM, Don Petcher <span dir="ltr"><<a href="mailto:petcher@covenant.edu" target="_blank">petcher@covenant.edu</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">I have not seen much discussion on media9 so I imagine it must be working fine for most.  I have been using movie15 for years for class presentations including movies, and now that movie15 is deprecated, I thought Iíd better move to media9.  So I tried a few of the simple examples I found on the web, but none of them work for me.  I just get a black rectangle where the movie should be, but it looks like the processor is being overwhelmed.<br>

<br>
I am trying to play mp4 files on a couple of Macs, both running OS X Mavericks (10.9.3) and Adobe Reader 10.1.10.  Could I be missing an important element in the setup like a media player? Have others been using media9?  I include the simplest example I tried after my signature.  Thanks.<br>

<br>
--Don Petcher<br>
petcher at covenant dot edu<br>
<br></blockquote><div><br></div><div><br></div><div>I use</div><div><br></div><div>{\usebackgroundtemplate{\includemedia[</div><div>      activate=pageopen,</div><div>      deactivate=pageclose,</div><div>      width=128mm, height=96mm,</div>
<div>      addresource=mymovie.mp4,</div><div>      flashvars={</div><div>         src=mymovie.mp4</div><div><span class="" style="white-space:pre">         </span>&loop=false</div><div><span class="" style="white-space:pre">            </span>&autoPlay=true</div>
<div>      }</div><div>      ]{}{StrobeMediaPlayback.swf}}</div><div>\begin{frame}[plain]</div><div><br></div><div><br></div><div>\end{frame}</div><div>}</div><div> </div></div></div></div></blockquote><div><br></div>This did work!  But why is it that you use a background template rather than simply defining a command to play the movie?  For example </div><div><div><br></div><div>\newcommand{\showmovie}[1]{\includemedia[</div><div>      activate=pageopen,</div><div>      deactivate=pageclose,</div><div>      width=128mm, height=96mm,</div><div>      addresource=movies/#1,</div><div>      flashvars={</div><div>         src=movies/#1</div><div><span class="Apple-tab-span" style="white-space:pre">           </span>&loop=false</div><div><span class="Apple-tab-span" style="white-space:pre">              </span>&autoPlay=true</div><div>      }</div><div>      ]{}{StrobeMediaPlayback.swf}</div><div>}</div><div><br></div><div>Then </div><div><br></div><div>\begin{frame}[plain]</div><div> \showmovie{mymovie.mp4}</div><div>\end{frame}</div><div><br></div></div><div>also works.  In any case, it is evident that the essential difference is in the parameters, not in the template. I did try something similar (using StrobeMediaPlayback) that I found on the web as well and it did not work.  So Iíll have to spend some time tracking down the parameters you gave me to see where the issue is. Thanks very much.</div><div><br><blockquote type="cite"><div dir="ltr"><div class="gmail_extra"><div dir="ltr"><br>
</div><div>However the problem could be with your mymovie.mp4</div><div><br></div>
</div></div>
<br></blockquote><div><br></div><div>mymovie.mp4 is just a placeholder for any number of movies I have been showing over the years (mostly commercial physics demos).  So no problem there.  </div><div><br></div><div>óDon</div><br><blockquote type="cite">----------- Please Consult the Following Before Posting -----------<br>TeX FAQ: <a href="http://www.tex.ac.uk/faq">http://www.tex.ac.uk/faq</a><br>List Reminders and Etiquette: <a href="http://email.esm.psu.edu/mac-tex/">http://email.esm.psu.edu/mac-tex/</a><br>List Archive: <a href="http://tug.org/pipermail/macostex-archives/">http://tug.org/pipermail/macostex-archives/</a><br>TeX on Mac OS X Website: <a href="http://mactex-wiki.tug.org/">http://mactex-wiki.tug.org/</a><br>List Info: <a href="https://email.esm.psu.edu/mailman/listinfo/macosx-tex">https://email.esm.psu.edu/mailman/listinfo/macosx-tex</a><br></blockquote></div><br></body></html>