[OS X Emacs] LaTeX cannot find its class/style files (obvious fixes attended to)

pdfinn at uwm.edu pdfinn at uwm.edu
Fri Jan 4 17:11:26 EST 2008

Dear list,

I would really like to get LaTeX running under Emacs, but am running into the
following problem: when I evoke LaTeX on a document it complains that it is unable
to find certain basic core style and class files.  (For example, a document
calling the``article'' class, LaTeX will complain that it cannot find ``article.cls'')

If I run LaTeX in the shell it works just fine.  If I evoke it through Emacs I run
into the above problem---this includes evoking LaTeX through Emac's term and shell

I have explicitly set (setenv "TEXINPUTS" ".:/paths/") in my .emacs (and my
.profile).  If I set a complete path to the individual files LaTeX cannot find
 in TEXINPUTS, LaTeX finds them, otherwise it doesn't.  So it seems LaTeX isn't
 tunneling into the directories---yet the variable TeX-file-recurse is set true.

- Mac OS 10.4.11
- Emacs 22.1.1
- Latest TeX build from Macports

Any advice would be greatly appreciated.


More information about the MacOSX-Emacs mailing list