[OS X Emacs] Switching from Carbon Emacs to Emacs.app

Peter Dyballa Peter_Dyballa at Web.DE
Sat Jan 5 15:11:21 EST 2008

Am 05.01.2008 um 19:37 schrieb Lindsay Stirton:

> /Library/Application\ Support/emacs already exists.

That's a problem with default HFS+: this aPPLE product can  
distinguish between file A and file a – but you can't have file A and  
file a. You can only have this *or* that (which creates some problems  
with public domain UNIX software). In UFS, the UNIX file system that  
does not know about resource forks, you can have both files at the  
same time. (For Mac OS X Server an HFS+ variant exists that allows  
both files (in some late Tiger version, or in Leopard), which only  
needs to be enabled in Mac OS X – but the original HFS+ volume will  
get re-formatted! So it might not be achieved with only one Mac and  
with only one disk. And it's not officially supported be Apple.)

> I am afraid I struggled a bit to understand this part of your  
> answer (although I
> don't doubt that the fault is mine). There is /usr/local/gwTeX/ 
> texmf.local in
> gwTeX.

Old gwTeX has the idea of TeX branches with more or less original (te) 
TeX based software (/usr/local/gwTeX/texmf, /usr/local/gwTeX/ 
texlive), then (usual?) local additions or maybe better: resources  
(for example configuration and format files) (/usr/local/gwTeX/ 
texmf.local), add-ons by Gerben Wierda (/usr/local/gwTeX/ 
texmf.gwtex), and finally things some user or system administrator  
might add. When gwTeX is updated it erases all "its own" branches and  
only leaves untouched /usr/local/gwTeX/texmf.pkgs – see /usr/local/ 

> style/polski.el tex-jp.el
> Cannot open load file: lpath.el
> make: *** [lisp] Error 255
> Macintosh:auctex-11.84 ljs$

Could be you were simply too fast! You wrote 'make install' above.  
How does it work when you first 'sudo make distclean', then configure  
again, and finally just invoke 'make' without anything else? Final  
step would be the 'sudo make install'. (Make without any option stops  
at the first error, passing to it -k will make run over all errors.)

I just tried it with configure and pure make, using the Emacs binary  
inside the Emacs.app bundle. It worked. After cleaning and re- 
configuring a 'make install' leads to errors similiar to yours ...

BTW: you can do all this in Emacs! Have you tried? Would you like to?  
You know how to create a *shell* buffer in Emacs, and how to change  
working directory to where AUCTeX resides – otherwise you would not  
have succeeded to run configure! Instead of invoking make on the  
command line you can

	M-x compile RET C-a sudo SPC C-e distclean RET

Too complicated with the prompt for the password in the echo-area?  
Then clean up from shell, configure again and try:

	M-x compile RET RET

Afterwards you can decide whether you would like to 'sudo make  
install' from Emacs instead of command line ...



With Capitalism man exploits man. With communism it's the exact  

More information about the MacOSX-Emacs mailing list