[OS X Emacs] Emacs -> Skim sync not workin' [SOLVED]

Christopher Menzel cmenzel at tamu.edu
Sat Sep 20 21:26:20 EDT 2008

> On 20 Sep 2008, at 19:32, Christopher Menzel wrote:
>> Brief followup here.  If Skim isn't running, the *first* time I do  
>> a Cmd-Shift-<leftclick> in an Emacs window it brings up Skim, and  
>> the corresponding point in the rendered document is displayed and  
>> highlighted.  After that, Cmd-Shift-<leftclick>ing simply shifts  
>> focus to the Skim window without any syncing.
> I believe that we send the correct info over to Skim, and the last  
> time I tried it, it worked for me. However, others have reported  
> very similar trouble.  I am cc'ing Tom McCormick, who might be able  
> to shed light on the issue - but according to my files, this issue  
> hasn't been solved.

Both Tom and I have found solutions to the problem, which in both our  
cases had distinct but similar origins.  Tom's problem had to do with  
loading a file into Aquamacs whose full pathname included the string  
"TeX".  Tom typed "tex" and Aquamacs was smart enough to do the  
conversion to upper case and load the file, but apparently the  
incorrectly typed name was stored for use in forward/inverse  
searching.  Apparently, when the script to do a forward search was  
called, it called Skim (hence the change in focus I reported) but of  
course didn't have the right name for the pdf file, so no joy.  I  
didn't have a problem with case, but the idea of using a filename to  
load a file that is different from the actual filename was the clue.   
I'm using iDisk syncing, which (as most folks probably know) creates a  
local copy of my .Mac iDisk and keeps them in sync.  I keep papers  
that I'm working on there so that I can always access up-to-date  
copies that I can work on on different machines.  (This is *really*  
cool, btw...)  However, I like having the folders containing all of my  
research papers in a single directory (~/Research/papers) beneath my  
Home directory, so I had created *symlinks* to the research folders on  
my (local) iDisk.  The problem with Aquamacs -> Skim syncing only  
arises if I use the symlink to load a paper into Aquamacs; if I call  
it instead via its actual path on the iDisk (e.g., /Volumes/c.menzel/ 
Research/papers/foo/foo.tex) I get Aquamacs -> Skim syncing back.

So the bottom line here is that something in the syncing process  
doesn't like symlinks.  (I'm guessing Applescript.)

Aquamacs Emacs and the Aquamacs community are great!  It's why I've  
donated to the project. ;-)

Chris Menzel

More information about the MacOSX-Emacs mailing list