[OS X Emacs] Possible bugs in 2.3a

Peter North PNorth at sydneyoperahouse.com
Tue Aug 2 03:27:57 EDT 2011

I'm running the latest version of Aquamacs and I've noticed some quirks, possibly due to my lack of programming skills.

Function key f9 makes the screen do an apple expose function. Control f1 does nothing. 

I've tried via customizations to have 2 windows side by side, but they don't appear. Nor does the cursor color, blue, appear. Windows side by side and cursor colour have to be set manually. 

I have the old style wireless keyboard [chunky keys and sloping back] help is under f14 but only changes cursor pointer to a question mark. 

However, following binding codes do work for anyone interested. 

(global-set-key [(f1)] 'my-function)

(global-set-key (kbd "S-<f1>") 'my-function)

(global-set-key [(control f2)] 'my-function)

(global-set-key [(meta f1)] 'my-function)

These bindings work for function keys 1 to 13 and 16. Function keys 14, 15 and 20 don't as they are OS X system bound and I can't rebind them. Global-unset key gives an error message on startup, as does define-key. Help key is also unbindable, even after getting the scan codes for the key.

I'd like to have 2 windows side by side on startup with a blue box cursor, but I can't make that work. 

I've enclosed my  customizations files for persual. Preferences.el is empty. My .emacs, [which makes the above bindings work, while the same code in customizations does not.] 

I also tried to write lisp code to get the 2 windows etc in an attach file called "Start"

Thanks to anyone who can help. 

Peter North.

PS The new version of Aquamacs is the best yet.

Please consider the environment before printing this email.
=====This message is intended for the addressee(s) named and may contain confidential information.
If you are not the intended recipient, please delete it and notify the sender.
Views expressed in this email are those of the individual sender and are not necessarily the views of the Sydney Opera House Trust=====
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: custom.txt
URL: <http://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20110802/90f29c34/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: start.txt
URL: <http://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20110802/90f29c34/attachment-0001.txt>

More information about the MacOSX-Emacs mailing list