[OS X Emacs] Re: problems updating org-mode on Aquamacs

Peter Salazar cycleofsong at gmail.com
Thu Feb 16 16:35:23 EST 2012

Thanks everyone for the replies! After days of debugging, I finally figured
out what was happening.

Robert, you were right that the problems with compiling were due to
interference from another version of Emacs. I deleted everything and
started over and had no trouble compiling.

It turns out the spinning pinwheel was due to an incompatibility between
the new version of org-mode and a function I'm running called
hidestarsfile, which made my .org files nice and readable in other text

Hidestarsfile worked fine with my old org-mode, but for some reason with
the new version it causes endless pinwheeling. I removed that function from
my .emacs file and now everything is running smoothly.

But now I need a new way to make my .org files easily readable outside
Emacs without showing big rows of stars. Even better would be if the stars
showed up as # so they'd be readable with Markdown.

On Tue, Feb 14, 2012 at 3:09 PM, Robert Goldman <rpgoldman at sift.info> wrote:

> > Date: Tue, 14 Feb 2012 00:57:54 -0500
> > From: Peter Salazar <cycleofsong at gmail.com>
> > Subject: [OS X Emacs] problems updating org-mode on Aquamacs
> > To: macosx-emacs at email.esm.psu.edu
> > Message-ID:
> >       <CAE+_6TxypRgEepv3K=eWXTkSRwZfV5NfvOOcbbR_kcm1=
> Kg0BQ at mail.gmail.com>
> > Content-Type: text/plain; charset="iso-8859-1"
> >
> > I'm running Aquamacs, which I downloaded as a .dmg and installed. It
> comes
> > with org-mode 6.33 or thereabouts. I'm trying to get a current version of
> > org-mode.
> >
> > I downloaded org-mode 7.8.03, did a setq load-path (cons to the org
> > directory, then used the package manager to install org from within
> > Aquamacs. I can verify that org now states its version as 7.8.03.
> >
> > But now whenever I save a file or open a new one, I get spinning rainbow
> > pinwheel of death. Do I have to compile the package somehow?
> >
> > I downloaded org-mode again and followed the instructions to do "make"
> and
> > "make install," but it didn't have any effect. Still pinwheel.
> >
> > So I tried downloading the Aquamacs binary and compiling that instead,
> but
> > I couldn't get it to work. Every time I try to compile Aquamacs using
> make
> > or /.build-aquamacs, it gets stuck on:
> >
> > Compiling
> > /Applications/aquamacs-emacs-binary/lisp/international/ucs-normalize.el
> >
> > All I want is to run Aquamacs with a recent version of org-mode... with
> > enough speed that I don't have to wait ten seconds every time I open a
> new
> > file!
> >
> > Any thoughts? Thanks for any help.
> I have been running org-mode from git under Aquamacs for ages now.  I am
> not able to determine from what you say above what might be going wrong.
> What I do is:
> 1. pull the aquamacs source from git
> 2. build with 'make all'.  Note that to do this I had to mess with the
>   Makefile to get it to find Aquamacs and use its byte compiler. [I won-
>   der if your bug is from getting some other emacs's byte-compiler on
>   your mac when you run the makefile...]
> 3. I doubt that `make install` will do anything great with Aquamacs
>   (but I might be wrong).  Instead, what I do is mess with the emacs
>   load-path in order to get it to load my org-mode library instead of
>   the one that comes with Aquamacs.  In my .emacs, I do:
> (add-to-list 'load-path (concat my-emacs-directory "org-mode/lisp"))
> (add-to-list 'load-path (concat my-emacs-directory
> "org-mode/contrib/lisp"))
> [You will see that I have defined my-emacs-directory first...]
> This is old-school -- I do this in my emacs config files rather than using
> customize, since I use emacs on multiple machines and operating systems.
> For
> more conventional uses there may be an approach using customize that
> achieves
> the same as the above, but does the right thing.
> _____________________________________________________________
> MacOSX-Emacs mailing list
> MacOSX-Emacs at email.esm.psu.edu
> http://email.esm.psu.edu/mailman/listinfo/macosx-emacs
> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20120216/f7596050/attachment.html>

More information about the MacOSX-Emacs mailing list