[OS X Emacs] Reverting buffer does not read local variables?

José Miguel Figueroa-O'Farrill j.m.figueroa at ed.ac.uk
Wed Feb 12 14:46:09 EST 2014


I have noticed the following odd behaviour for some time.  I'm not sure if it is particular to Aquamacs or if other emacsen behave in the same way.

I am editing a XeLaTeX document.  Since my default TeX engine is pdflatex, I have the following local variables block at the end of the file:

% Local Variables:
% coding: utf-8
% mode: LaTeX
% TeX-command-default: "XeLaTeX"
% TeX-engine: "xetex"
% End:

I work on this document on two machines (a desktop at work and a laptop at home) which I synchronise twice daily and on which I run Aquamacs uninterruptedly for days.  This means that whenever I sync after having worked on the file, one of the two machines has an Aquamacs session with a buffer visiting a file which has changed on disk and hence needs to revert.  When I revert via the revert button, it is as if TeX-command-default seems to go back to "LaTeX", contrary to the Local Variables block.  I say "as if" because what happens is that when I C-cC-c it offers "LaTeX" instead of "XeLaTeX" as the default command.

Is this normal behaviour?  A bug?  Customisable?  I've googled without success, whence this email.

Thanks in advance,


Prof José Figueroa-O'Farrill
School of Mathematics
University of Edinburgh
PGP Key: 0x6A6BD529 (MIT PGP Key Server)

The University of Edinburgh is a charitable body, registered in Scotland, with registration number SC005336.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 203 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <https://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20140212/55e12684/attachment.asc>

More information about the MacOSX-Emacs mailing list