[OS X Emacs] Reverting buffer does not read local variables?

David Reitter david.reitter at gmail.com
Wed Feb 12 15:20:56 EST 2014

Hi José,

Nice to hear from you.  Hope all is well (and days are not too short) in Edinburgh.

I don’t have a clear-cut answer, but I think over the years, the XeTeX  or XeLaTeX command (which was a custom addition in Aquamacs, based on user requests) was replaced by a TeXing option provided by AUCTeX.   I suspect that the TeXing option might or might not be set by TeX-engine, but that the command is (now) LaTeX.

Can anyone corroborate this hypothesis?

- David

http://aquamacs.org -- Aquamacs: Emacs on Mac OS X
http://aquamacs.org/donate -- Could we help you? Return the favor and support the Aquamacs Project!

On Feb 12, 2014, at 2:46 PM, José Miguel Figueroa-O'Farrill <j.m.figueroa at ed.ac.uk> wrote:

> Hi,
> I have noticed the following odd behaviour for some time.  I'm not sure if it is particular to Aquamacs or if other emacsen behave in the same way.
> I am editing a XeLaTeX document.  Since my default TeX engine is pdflatex, I have the following local variables block at the end of the file:
> % Local Variables:
> % coding: utf-8
> % mode: LaTeX
> % TeX-command-default: "XeLaTeX"
> % TeX-engine: "xetex"
> % End:
> I work on this document on two machines (a desktop at work and a laptop at home) which I synchronise twice daily and on which I run Aquamacs uninterruptedly for days.  This means that whenever I sync after having worked on the file, one of the two machines has an Aquamacs session with a buffer visiting a file which has changed on disk and hence needs to revert.  When I revert via the revert button, it is as if TeX-command-default seems to go back to "LaTeX", contrary to the Local Variables block.  I say "as if" because what happens is that when I C-cC-c it offers "LaTeX" instead of "XeLaTeX" as the default command.
> Is this normal behaviour?  A bug?  Customisable?  I've googled without success, whence this email.
> Thanks in advance,
> 	José
> Prof José Figueroa-O'Farrill
> School of Mathematics
> University of Edinburgh
> PGP Key: 0x6A6BD529 (MIT PGP Key Server)
> The University of Edinburgh is a charitable body, registered in Scotland, with registration number SC005336.
> _____________________________________________________________
> MacOSX-Emacs mailing list
> MacOSX-Emacs at email.esm.psu.edu
> https://email.esm.psu.edu/mailman/listinfo/macosx-emacs
> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4151 bytes
Desc: not available
URL: <https://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20140212/4370de6e/attachment.p7s>

More information about the MacOSX-Emacs mailing list