[OS X Emacs] Delay opening HTML files from a shell

Braun, Michael braunm at mail.smu.edu
Mon Jul 15 21:45:52 EDT 2019

If I may, I’d like to bring this issue back to the discussion.  I have tried all combinations of launching Aquamacs with and without configurations, and manually from the terminal, including with the -q option.  I am running the latest nightly build.

I’m happy to try to diagnose the problem myself, but I truly have no idea where to look next.


On Jun 6, 2019, at 9:19 PM, David Reitter <david.reitter at gmail.com<mailto:david.reitter at gmail.com>> wrote:


1.  I’m sorry I wasn’t more clear, but the replication steps you took do not relate to the problem.  The issue is not about opening Aquamacs from a Terminal shell.  The problem is opening an HTML file from within a process that is running from within Aquamacs.  So, Aquamacs is running, I open a shell process with M-x shell, and then try to open a file.  Another way to replicate is to start an ESS process (M-x R), and then ask for an HTML help file ( ?mean ) .

BTW, although my problem was with HTML files, I can replicate Win Treese’s delay when opening a text file from within an Aquamacs shell.  In fact, not only do I get this problem when TextEdit is the default reader, there is also a delay when text files are opened by default with Aquamacs!

I did try that earlier too — no replication, instant response.
The case of “?mean” also works perfectly.

But just in case, I re-cloned the repository (a pull and rebuild generated errors), and recompiled using ./build-aquamacs.  The results:

That has to do with an Emacs build problem — I’ll let them fix it.  They probably already have in a newer version.

Either way, we offer pre-made nightly builds on the website.

3.  I ran the lrregister command below, as requested, and then restarted my computer.  This did not solve the problem.

OK, thanks.

I’m assuming you’re not getting this delay when opening a file from Finder, dragging/dropping onto the Aquamacs icon in the Dock, or when typing “open x.txt” from a shell in Terminal, correct?

Again, I’d ask that you try to replicate with an Aquamacs started without configuration (Help->Diagnose), although I suspect this might just open the file in the Aquamacs that is already running with configuration.  In that case one would have to manually start it with “-q” from the command line or remove all config files.


MacOSX-Emacs mailing list
MacOSX-Emacs at email.esm.psu.edu<mailto:MacOSX-Emacs at email.esm.psu.edu>
List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx

Michael Braun, Ph.D.
Associate Professor of Marketing, and
  Corrigan Research Professor
Cox School of Business
Southern Methodist University
Dallas, TX 75275
braunm at smu.edu<mailto:braunm at smu.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20190716/9eefb046/attachment.html>

More information about the MacOSX-Emacs mailing list