[OS X Emacs] aquamacs interacting incorrectly with git (and .org site not working)

David Romano dromano at stanford.edu
Mon Mar 4 15:02:37 EST 2019

On Mon, Mar 4, 2019 at 6:10 AM David Reitter <david.reitter at gmail.com>

> On Mar 3, 2019, at 7:34 PM, David Romano <dromano at stanford.edu> wrote:
> >
> > Thanks David (and Peter),
> >
> > I'm not familiar with emacsclient, so I may to look into Peter's
> suggestion, but I'm not sure I understand when you say
> > If you run Aquamacs with the GUI, the command returns immediately.
> >
> > I thought that's what I was doing:  Having run `git config --global
> core.editor aquamacs`, the Aquamacs GUI popped up when I ran `git commit`,
> but after I saved the buffer or quit the GUI, `git log' showed there was no
> effect.  Or am I misunderstanding you?
> Check the terminal window while you’re still editing the file.  I bet the
> message is there already before you save / quit Aquamacs.

Here's a quick experiment at the terminal in an empty directory called
'aqua' that shows what I mean:
$ git config --global  core.editor aquamacs
$ git init
$ echo "a" > a
$ git add .
$ git commit
Aborting commit due to empty commit message.

Here `git commit` triggered an COMMIT_EDITMSG file to be opened, but
completed at the same time, preventing me from being able to write
anything. This is definitely odd behavior.

> If you do M-x server-start in Aquamacs, and then use EDITOR=emacsclient,
> it should work — because if you call emacsclient from the command line, it
> will wait until you’re done editing the file.  You don’t need to quit
> Aquamacs.

I tried this and it works exactly as expected -- so thank you -- but I'm
still curious what might be going wrong in the previous case.

Thanks again,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20190304/9d2109b0/attachment.html>

More information about the MacOSX-Emacs mailing list