[OS X Emacs] aquamacs hanging when using skim as previewer

Win Treese treese at acm.org
Wed Nov 13 11:25:03 EST 2019

> On Nov 12, 2019, at 10:08 AM, Art Werschulz <agw at comcast.net> wrote:
> Using Aquamacs 3.5 andSkim 1.6.4 on macOS Mojave (10.14.6).
> After LaTeX-ing a file, I run C-c C-c to view the file.  The minibuffer says
> 	View command: (lambda() (aquamacs-call-viewer 53 "foo.tex"))
> I hit return, and then I get the spinning beach ball.  I eventually wind up doing a Force Quit on Aquamacs.
> Just on a whim, I started Skim "by hand" and then restarted Aquamacs, and this problem didn't occur.  So maybe the problem only will arise if I don't have Skim running before I try previewing the PDF file.

Hi, Art.

I usually don’t use Skim, but I tried to recreate this. It ended up working for me, but I noticed that I got a permissions popup from MacOS when I first invoked Skim from Aquamacs. Did you see anything like that when you ran it later?

Have you tried again starting Skim from Aquamacs after seeing it work when you started it beforehand?

I know this isn’t terribly helpful!

Win Treese
Aquamacs maintainer
treese at acm.org

More information about the MacOSX-Emacs mailing list