[OS X Emacs] pop-to-buffer error

Win Treese treese at acm.org
Mon Dec 20 18:17:04 EST 2021

Hi, Devin. That seems strange. I don’t regularly use ESS, but I tried some simple things to see if I could reproduce the problem you are seeing.

I don’t see it either with no-initialization Aquamacs 3.5 or with my regular configuration (which, of course, doesn’t include any configuration for ESS). 

I think you tried a good experiment, and the outcome is puzzling. When Aquamacs is started without customizations, it still does all of the packaged initialization, which includes things beyond what basic Emacs does. (That being said, the initialization process is fairly complicated, and I may not fully understand all the subtleties.). 

Some things to possibly try:
1. Is there anything in the *Messages* buffer indicating a problem?
2. Does the R process start up properly, and the *R* buffer in existence?
3. If you set the variable debug-on-error to t before trying the ESS command, it may give some insight into where in the code things go wrong.
4. If none of the easy things turn up anything, if you want to share your config files with me, I can try to reproduce it from that.



Win Treese
Aquamacs maintainer
treese at acm.org

> On Dec 14, 2021, at 11:04 AM, Devin Caughey <devin.caughey at gmail.com> wrote:
> Hello,
> For some months now I have been encountering an error every time I try to evaluate an ESS buffer without an R buffer already running -- for example, by running `ess-eval-line-and-step`. When I do this, I get the following error (after selecting the working directory): "pop-to-buffer: Wrong type argument: window-live-p, nil". This error does not occur if I run vanilla Aquamacs with no customizations. It also does not seem to be caused by what is in my customizations.el or Preferences.el files, since the error does not appear after I evaluate these files in vanilla Aquamacs. Rather, my best guess is that it has something to do with the plugins loaded when Aquamacs starts up normally rather than in vanilla mode. I've updated all my packages but I can't seem to pinpoint the problem. Any idea what might be going on?
> Thanks!
> Devin
> p.s. I am running Aquamacs 3.5 on MacOS 12.0.1.
> _____________________________________________________________
> MacOSX-Emacs mailing list
> MacOSX-Emacs at email.esm.psu.edu
> https://email.esm.psu.edu/mailman/listinfo/macosx-emacs
> List Archives: http://dir.gmane.org/gmane.emacs.macintosh.osx

More information about the MacOSX-Emacs mailing list