[OS X TeX] Unable to install TeX Foundation and Programs

Henrik Holm list at henrikholm.com
Sat Nov 16 17:37:37 EST 2002

First of all:  from your directions and tips, I was able to fix it.

Probably I am the one who have goofed -- but still, the problems might
be of interest to you.  If you want to make things completely foolproof,
you need to take into account the ingenuity of complete fools :)

  (the above sentence is plagiarized (and probably destroyed) from
somewhere; but I can't remember where...)

> What *might* be the 
> case is that some part of texcconfig is taking a lot of time. This 
> might happen when your HOME environment variable has an extra '/' at 
> the end

OK, I checked, and this seems not to be the case

  % echo $HOME

> (the old installer checked for that, I'll put that in the new 
> package as well when I get around to that later), something you have to
> tinker in NetinfoManager for so it is highly unlikely. 

> Another possibility is that you have a lot of files in
> ~/Library/texmf (like an old texmf tree).

Uuh, that is definitely the case:  when I migrated from Linux I put my
texmf-local tree there (because I mis-understood your directions.  Now I
know that it is supposed to be in /usr/local/teTeX/share/texmf.local,
right?) so there was about 40MB of stuff there.  I renamed it to
~/Library/texmf-local-old and am tried again.

> In any case, the first thing to try is to be *very* patient and wait 
> for *hours* before deciding something is really hanging. (Moving 
> ~/Library/temf out of the way if it exists might be a good idea anyway).

OK, it turns out I didn't need this: it was indeed hanging.

> Using "ps laxww" when the ocnfiguration script is running might tell 
> you (and me) more.

Yup, here are the relevant excerpts:

root    3396   0.0  0.1     1300    492  ??  Ss    2:59PM   0:00.10
    perl /Users/henrik/Desktop/TeX/texbinaries.ii2/texbinaries.configure
root    3399   0.0  0.1     1828    492  ??  S     2:59PM   0:00.01
    sh -c texconfig help 2>&1 | grep localsetup >/dev/null
root    3400   0.0  0.1     2084    832  ??  S     2:59PM   0:00.13
    sh /usr/local/teTeX/bin/powerpc-apple-darwin-current/texconfig help
root    3401   0.0  0.0     1416    304  ??  S     2:59PM   0:00.02
    grep localsetup

(sorry 'bout the line-breaks; my mailer is very persistent in not
letting me post with lines longer than 80 characters)

It is often interesting to run commands that seem to be offensive from
the command-line, so that is what I did:

 % sh -c texconfig help

and sure enough, the first thing that happened was that the following
screen appeared:

texconfig has found the following environment variables set:

 BIBINPUTS = /Users/henrik/Library/texmf/tex/Henrik-private/bib

This path prohibits a default expansion. as it contains no : at either
end, nor :: somewhere in the middle.  Please make sure, that these paths
are ok, and otherwise change or unset them.  If you continue with wrong
values for the above variables, texconfig might run into trouble when
locating files on the disk.

Note that you can refer to the default path by giving an "empty" path
component (i.e. a colon in front or in the end, or a doubled colon
somewhere in the middle).

If you set TEXINPUTS, e.g. to :~/TeX/macros, (La)TeX will search along
the default path and then in ~/TeX/macros.

For more information, see the Kpathsea and the teTeX manual.

Press RETURN to continue (or Control-C to abort)... ^C

Clearly, texconfig waits for input.  

The setting of the BIBINPUTS does make sense, because that is where I do
have my .bib files.  But I am quite puzzled, because I cannot remember
that I set it!  I searched trough my ...rc-files with a 'grep INPUTS
~/.??*', but the only thing that came up was a 'setenv TEXINPUTS :./fig'
(which makes sense; I remember that I set that one).  After some
searching, I found the BIBINPUTS setting in the
~/.MacOSX/environment.plist file.  But here comes the strange thing: it
was dated Nov 7 2002.  And the ~/.MacOSX/environment.plist~ file was
dated Jul 14 2002 -- and did not contain the setting of BIBTEX.

I am absolutely positive that I have not fiddled (at least not directly)
with the environment.plist file the last few months (I had forgotten
that it existed, and usually I don't forget that fast.)  I do think that
I did fiddle with it some months ago, though, in order to set the
TEXINPUTS variable.

I installed Jaguar on Nov 3.  It might be that Nov 7 was the first time
after installing Jaguar that I ran TeXShop, but I am not absolutely
sure.  Could it be that TeXShop has altered my environment.plist and as
such has set the BIBINPUTS variable?  I find that hard to believe,
though, since my TeXShop is v.1.19, from late March 2002.

Anyway:  I removed environment.plist and I was able to install teTeX.
It seems to work now; I have (successfully) compiled the paper I am
currently working on with the new installation.


Mac TeX info, resources, and news can be found at:
List archives can be found at:
See message headers for list info.

More information about the MacOSX-TeX mailing list