[OS X TeX] TeXShop won't open .ps in jaguar

Axel E. Retif axretif at att.net.mx
Thu Oct 10 08:05:43 EDT 2002

On Wednesday, October 9, 2002, at 09:53  AM, tom wrote:

> Since upgrading to 10.2 TexShop no longer opens .ps files. I double 
> click
> on a .ps, TeXShop opens, but nothing happens. I'm using the latest 
> teTeX
> and TeXShop versions. TIA for any suggestions....

I'm running 10.2.1 and TeXShop 1.2. I tried drag-dropping on TeXShop a 
.ps file named

VI Concurso—Áreas_gráfica.ps

and the console.log (viewed through DesktopConsole.app) immediately 
Error: /undefinedfilename in (VI)
Operand stack:

Execution stack:
    %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--   --nostringval-- 
   --nostringval--   false   1   %stopped_push   --nostringval--   
Dictionary stack:
    --dict:932/983(ro)(G)--   --dict:0/20(G)--   --dict:66/200(L)--
Current allocation mode is local
Last OS error: 2
Aladdin Ghostscript 6.01: Unrecoverable error, exit code 1
which is very similar to what Mr. Bruno Voisin ---see Subject: [OS X 
TeX] Feature of epstopdf (probably normal)--- got when running epstopdf.

In his case I guess his file name started with "3/Version" and then a 
space, as implied by his comment
Sorry, I sent my latest message too quickly: I did another test, it's 
not the dot "." but the space " " in paths, which is confusing epstopdf
(or rather to Ghostscript, as we can see in his and mine error 

I then renamed my file to "grafica.ps" (no spaces, no em dash, no 
accents) and drag-dropped again on TeXShop... and nothing happened, not 
even an error message. But then I quitted TeXShop and tried again... 
and it came out perfectly (viewed in TeXShop or Preview, it seems to 
lack some lines, but in Acrobat Reader it is displayed as it should).

To proof Mr. Voisin theory, I renamed again the file to 
VI_Concurso—Áreas_gráfica.ps... and it worked! So he's quite right 
---it is spaces what you should avoid in your file names.

(Anyway, I'm no longer using em dashes, because you can't type an em 
dash in Terminal.app.)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 2148 bytes
Desc: not available
URL: <http://email.esm.psu.edu/pipermail/macosx-tex/attachments/20021010/e59d07c1/attachment.bin>

More information about the MacOSX-TeX mailing list