[OS X TeX] OT: Using FontForge to create .otf.dfont files from .pfb files

Bruno Voisin bvoisin at mac.com
Thu Apr 7 11:10:02 EDT 2005

To those experienced in using FontForge to create Mac fonts:

I have been using FontForge to open, then edit (modifying glyphs 
manually) and finally save in Mac format a free .pfb font (the font was 
originally in Classic LWFN PostScript format, converted to .pfb using 
t1unmac). In order to preserve the PostScript quality, I chose the Mac 
OpenType format .otf.dfont, as for the Latin Modern fonts installed by 
the TeX i-Package.

The font is then used in Illustrator 10, for incorporation in a logo. 
Alas, in Illustrator every single key I type seems to be shifted one 
character: when typing A I get B, when typing B I get C, etc. This does 
not happen if I choose the Mac TrueType format .dfont, but in that case 
there is a conversion from PostScript to TrueType which, I imagine, 
inevitably means some slight loss in quality. This does not happen 
either with the original .pfb font, saved to .otf.dfont format without 
being modified first.

I have tried many different combinations, to no avail. It seems 
changing the name of the font using the menu item Element > Font Info > 
Names has an influence on whether the problem shows up or not. I have 
the impression, too, that the problem is possibly linked with the value 
of the first character (Ox0000, corresponding to .notdef), or with the 
info entered for this character inside Element > Glyph Info > Unicode 
(in some of the attempts I did, the default Unicode Value and Char were 
U+fffd and "!", while in others they were -1 and "" which I assume is 
more correct).

Having tried many different combinations, at some point I had the fonts 
display correctly in Font Book and only exhibit the problem in 
Illustrator 10, while at others the problem showed up in both. In some 
other attempts the problem was not character substitution, but rather 
unwanted white spaces showing up here and there while some characters 
were put on top of each other. I have also tried changing the font 
encoding in FontForge, in case that was the source of the problem, but 
it only made things worse.

After spending practically 1.5 days on the issue I am about to give up, 
but before doing so:

- Given the Mac Latin Modern fonts originated from the same .pfb format 
but do not display this problem, does this mean some steps have to be 
taken (other simply opening the .pfb file and saving to .otf.dfont) in 
order to avoid the above problem?

- Or is the bug in Illustrator 10 rather than FontForge, and is this 

Thanks for any hint,

Bruno Voisin

--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list