[OS X TeX] OT: Using FontForge to create .otf.dfont files from .pfb files

Bruno Voisin bvoisin at mac.com
Fri Apr 8 13:07:54 EDT 2005

Le 7 avr. 05, à 17:10, Bruno Voisin a écrit :

> To those experienced in using FontForge to create Mac fonts:
> I have been using FontForge to open, then edit (modifying glyphs 
> manually) and finally save in Mac format a free .pfb font (the font 
> was originally in Classic LWFN PostScript format, converted to .pfb 
> using t1unmac). In order to preserve the PostScript quality, I chose 
> the Mac OpenType format .otf.dfont, as for the Latin Modern fonts 
> installed by the TeX i-Package.
> The font is then used in Illustrator 10, for incorporation in a logo. 
> Alas, in Illustrator every single key I type seems to be shifted one 
> character: when typing A I get B, when typing B I get C, etc. This 
> does not happen if I choose the Mac TrueType format .dfont, but in 
> that case there is a conversion from PostScript to TrueType which, I 
> imagine, inevitably means some slight loss in quality. [...]

In case some people looked at this:

The problem was solved by saving the modified font in Classic 
PostScript font format, namely a FFIL TrueType screen font suitcase 
(corresponding to FontForge's "True Type (Resource)" format) and a LWFN 
PostScript printer font file (corresponding to FontForge's "PS Type 1 
(Binary)" PFB format, converted to LWFN by t1mac), and then putting the 
result in the Classic font folder, namely /System Folder/Fonts/.

That doesn't explain the behaviour observed with the .otf.dfont format, 
namely a font behaving properly in Cocoa applications (Font Book, 
TextEdit, etc.) but behaving erroneously in Illustrator 10 (a space on 
the keyboard yielding "!" on screen and print, A yielding B, 1 yielding 
2, etc., all characters being seemingly shifted by one code point 
between keyboard input and Illustrator output). I tried altering every 
possible option in the FontForge settings or in the "Generate Fonts..." 
dialog, with no luck: only abandoning the .otf.dfont format solved the 
problem. I believe this to imply a bug in either Illustrator 10 or 
FontForge (or OS X), but I won't have time to investigate the issue 

Bruno Voisin
--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list