[OS X TeX] [ANN] TCOBrowser-0.84

Adam R. Maxwell amaxwell at mac.com
Sat Jul 9 22:45:51 EDT 2005

On Jul 9, 2005, at 14:41, Peter Dyballa wrote:

> Am 09.07.2005 um 18:06 schrieb Adam R. Maxwell:
>> This release fixes an issue that prevented local documentation  
>> from being found on Tiger.
> Dear Adam,
> I don't want to be intrusive or rude (although I usually are) but  
> there seems to be something, that manifests itself in the Console as:
> 2005-07-09 22:09:00.524 TCOBrowser[20138] Binding selectedObject  
> cannot be bound to <NSUserDefaultsController: 0x137bc0>[applies  
> immediately: YES]

Under what circumstances did you see this message?  I haven't seen  
it, but I've done almost no testing with Panther, since I have to  
reboot into Tiger to recompile after making any changes to the code.

> Then I browsed through the entries and found "fonteinf" which  
> looked promising. And it provided a PDF I wanted to read (or browse  
> at least). So I clicked on it in the drawer and that's what the  
> Console tried to tell me:
> 2005-07-09 22:38:10.019 TCOBrowser[20138] CFLog (21): Error loading  
> @executable_path/../Frameworks/MSL.framework/Versions/A/MSL:  error  
> code 0, error number 2 (dyld: /Applications/TCOBrowser.app/Contents/ 
> MacOS/TCOBrowser can't open library: @executable_path/../Frameworks/ 
> MSL.framework/Versions/A/MSL  (No such file or directory, errno = 2)
> )

Hmmm...I haven't the faintest idea what MSL.framework is.  TCOBrowser  
certainly isn't linked to it, but apparently it's bundled with some  
application that you have.  My guess is that you have some browser  
plugin trying to load the PDF, and the webview doesn't work with it?   
Oh, I just saw your note below, and it appears that this is correct ;).

You should be able to control-click and save the linked file (at  
least, that worked last time I tried it).  I just single-clicked the  
fonteinf.pdf file in the web drawer on Tiger, and it loaded right  
into the drawer, which is a feature that I didn't even know about!   
Looks like I need some kind of magnification feature in the drawer  

> A form came up showing the contents of /Applications, from which I  
> first tried to select TeXShop (there is no better PDF viewer  
> around), but it was grey. Acrobat Reader 5.1 was unusable grey too,  
> Adobe Reader 6.0.2 seemed to vanish when I opened it's directory,  
> only Adobe Reader 7 was -- and this one produced the messages.  
> TCOBrowser 0.84 survived all this, while the drawer was blank. With  
> the blue arrow I could return to entry's contents ... I could not  
> read the PDF file with the help of TCOBrowser.

Sorry about that, but I'm just not sure what to tell you.  If you  
have Interface Builder, try opening up TCOBrowser's MainWindow.nib,  
double-click on the "web drawer" view, select the WebView and hit cmd- 
shift-i to get info on it, then uncheck "Enable plug-ins" and see how  
it goes.  If that doesn't make sense, I can send you a build with  
that done.


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the MacOSX-TeX mailing list