[OS X TeX] spaces in names

Themis Matsoukas matsoukas at psu.edu
Thu Mar 16 14:06:48 EST 2006


I was under the impression that it is simply not possible to typeset  
through TeXShop a filename with spaces, but I just tried with "test  
1.tex" (w/o the quote marks) and it worked, as others just reported.

Having said that, you will be better off  if you avoid spaces in the  
names of all files involved in latex (.tex, .eps, etc). As a human  
being you will probably be unhappy about this. But latex is not for  
human beings, it is for perfectionists ---who are never happy  
anyway... :)


On Mar 16, 2006, at 12:55 PM, Massimiliano Gubinelli wrote:

> thanks to all.
>  to clarify my problem: I do not mind of \input files. All I'm  
> trying to do is to compile a simple tex file whose name is "test  
> 1.tex" (with a space between test and 1). If I open it in TeXShop  
> it doesn't compile either. The log window says
> This is pdfeTeX, Version 3.141592-1.30.3-2.2 (Web2C 7.5.5)
> \write18 enabled.
> entering extended mode
> ! I can't find file `"test 1.tex"'.
> <*> "test 1.tex"
> Please type another input file name:
> as in my previous attemps from the command line.
> I do not understand why TeX puts double quotes around the file name  
> when it reports the error.
> Can somebody reproduce this?
> I have TeXshop 2.08 and the Gerben Installation dated 2005/10/09.
> thanks,
> max
> PS: I love Emacs...
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list