[OS X TeX] Aquamacs and preview-latex

Chris Menzel cmenzel at tamu.edu
Sun Nov 12 18:57:24 EST 2006

Has anyone experienced any problems with preview-latex recently, esp on
an Intel Mac?  When I preview some LaTeX code (or a region or buffer
...) the bitmaps are inserted in my Emacs buffer but they all contain a
huge amount of whitespace.  Look here to see what I mean: 


I highlighted the region in the screenshot before grabbing it to make
the whitespace in the bitmaps more visible.  I have reported this
problem to the emacs bugs list and have corresponded with David Kastrup
(the maintainer of the auctex package) about it; I've tried installing
the newest version of auctex and have tried different versions of
ghostscript; I've checked that I'm using current versions of relevant
auxiliary programs like pdf2dsc; I've tried using Carbon Emacs instead
of Aquamacs Emacs.  All to no avail.  After installing TeXLive this
morning (via i-Installer), things are actually *better*, in that all of
my math code in a previewed region or buffer is being displayed --
before only the first string of code was being displayed (with the
excessive whitespace).  But this is still intolerable, obviously.  I run
Ubuntu Linux in a virtual machine (thanks to Parallels Desktop) and
preview runs flawlessly therein.  But I'd prefer to stay in OS X and use
Aquamacs Emacs, which has several advantages over the Linux setup.

This is all the more frustrating in light of the fact that preview was
working under Carbon Emacs a couple of months ago.  Unfortunately, I do
not know what I, or something, did in the meanwhile to break it.

Any suggestions much appreciated.

Chris Menzel

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the MacOSX-TeX mailing list