[OS X TeX] problem with \usepackage{times}

Raymond N. Greenwell matrng at hofstra.edu
Thu Jun 21 14:43:01 EDT 2007

On Jun 21, 2007, at 2:16 PM, Jonathan Kew wrote:

> On 21 Jun 2007, at 5:44 pm, Raymond N. Greenwell wrote:
>> On Jun 21, 2007, at 4:28 AM, Bruno Voisin wrote:
>>> Le 21 juin 07 à 09:07, Jonathan Kew a écrit :
>>>> On 21 Jun 2007, at 12:48 am, Raymond N. Greenwell wrote:
>>>>> I recently got a new iMac and am now running OS 10.4.9. My old  
>>>>> TeXShop from my old iMac (running 10.3.9) no longer worked, so  
>>>>> I downloaded the TeXShop and TeX Live package MacTeX-2007, and  
>>>>> I'm now running TeXShop 2.10beta8. All is well except for the  
>>>>> command \usepackage{times}, which gives the error message: "***  
>>>>> font ptmr7t not found in psfonts.map or host system; will  
>>>>> substitute Helvetica glyphs".
>>>> This sounds like it's coming from the XeLaTeX engine; you must  
>>>> have chosen this rather than regular LaTeX, and it is unable to  
>>>> use the "virtual fonts" associated with the "times" (or  
>>>> "mathptmx") packages, unless you also configure it to use the  
>>>> xdvipdfmx output driver.
>> "This is a test" is in Times, but the math appears to be in  
>> Helvetica, and the rightarrow (or "to") comes out as an  
>> exclamation point. If I remove all the usepackage commands,  
>> everything is fine in Computer Modern. I really want to have Times  
>> for the text that's not in math, but with correct math  
>> typesetting, as I had in the earlier version of TeXShop on my old  
>> machine.
>> Thanks to the other responders, but I was using LaTeX, not XeLaTex  
>> or pdflatex, and I didn't add any fonts to my system after  
>> installing MacTeX-2007.
> Do you still get a message (as you originally cited, see above) of  
> the form "*** font <something> not found in psfonts.map or host  
> system; will substitute Helvetica glyphs"?
> I am pretty confident that the only source of this message is the  
> output driver used by xelatex, and therefore this would indicate  
> that your TeXShop is (perhaps inadvertently) configured to use  
> xelatex; this in turn would account for the failure of certain font  
> packages (those that depend on "virtual fonts").
> To confirm this, please check the first lines in the TeXShop  
> console output, where the program doing the actual typesetting  
> (which is not TeXShop itself but an underlying command-line tool)  
> introduces itself, with words such as
>   "This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)"
> or
>   "This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6)"
> or similar.
> JK
As a matter of fact, I am still getting the message: "*** font  
zptmcm7m not found in psfonts.map or host system; will substitute  
Helvetica glyphs". And in the window, I see the message "This is  
XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6)".

To fix this, I tried going to the preferences, under miscellaneous,  
and changed the TeX Program from xetex to tex, and the Latex Program  
from xelatex to latex. Now I get the message: "This is pdfTeXk,  
Version 3.141592-1.40.3 (Web2C 7.5.6)" with no error messages. The  
only small glitch is that the output comes out as a dvi file rather  
than a pdf file, but double clicking on that file causes it to open  
as a pdf. I get the warning message "The file was opened with  
MacOSRoman encoding. The file could not be opened with Unicode  
(UTF-8) encoding because it was not saved with that encoding." But I  
don't see any problem with the pdf file, so I guess my problem is  


Raymond N. Greenwell         matrng at hofstra.edu
Professor of Mathematics     (516) 463-5573
103 Hofstra University
Hempstead, NY 11549-1030

------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list