[OS X TeX] [ANN] Excalibur 4.0.3

Rick Zaccone zaccone at bucknell.edu
Mon May 28 08:19:14 EDT 2007

On May 28, 2007, at 7:40 AM, Victor Ivrii wrote:

> On 5/28/07, Rick Zaccone <zaccone at bucknell.edu> wrote:
>> Are you using an Intel Mac?  If you ask it to run under Rosetta does
>> it crash?  Click on Excalibur and select Get Info from the File
>> menu.  Select "Open using Rosetta".  If that fixes it, then it's an
>> architecture issue.  A copy of your preferences file would be a big
>> help.
>> Rick
> Yes, it is Intel and I tried again. Now it does not crash in native
> mode but when I tried Rosetta it crashed. Then in native mode it ran
> fine again
> PS I did not reboot computer between my current and the previous
> series of attempts
>                  Victor

I've identified the problem and I'll try to get a fix out today.   
It's an endian issue.  If your preferences file was created with  
Excalibur 4.0.2, Excalibur 4.0.3 will crash when trying to read it on  
an Intel machine.  It should work with Rosetta though.

Conversely, if you created the preferences file with Excalibur 4.0.3  
and try to read it when using Rosetta, it will crash.

Several people have reported problems opening the .dmg file and it  
works for others.  I'm not sure why this is.  I think we'll just  
replace it with a .zip file, maybe after I have fixed this bug.


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list