[OS X TeX] problems with Minion Pro package with gwTeX

Ted Sider sider at philosophy.rutgers.edu
Thu May 31 17:28:43 EDT 2007

On May 31, 2007, at 4:55 PM, Peter Dyballa wrote:

> Am 31.05.2007 um 21:50 schrieb Ted Sider:
>> Pete, thanks for the suggestion.  Didn't work though.  In the  
>> list, MinionPro was initially not checked.
> The latter is correct because it's no default MAP file fragment. At  
> least the MAP file fragment *was found* now, i.e. it *does exist*  
> for (La)TeX (in a GUI application). A good sign.
>> I clicked the check box, finished the procedure, but it still  
>> doesn't work.
> That's natural, because you did not remove the debris (as you  
> described) from invoking updmap! From this you'll probably have:
> 	~/Library/texmf/web2c/updmap.cfg
> 	~/Library/texmf/fonts/map/{dvipdfm,dvips,pdftex}/updmap
> Particularly the MAP files in ~/Library/texmf/fonts/map/*/updmap  
> will be found before the new ones created by i-Installer.
>> (By the way, I also did this for comparison on the machine where  
>> everything is working fine, and MinionPro does not show up at all  
>> - it doesn't show up either checked or unchecked.)
> This cannot be. If you are merely unhuman and cannot make mistakes,  
> then I think you have for the GUI applications and in Terminal  
> different TeX setups active. Otherwise I can't explain why one  
> thing sees what the other can't ...


about debris:  there was no ~/Library/texmf/web2c/updmap.cfg.  Also  
there was no subdirectory ~/Library/texmf/fonts/map/ 
{dvipdfm,dvips,pdftex}/updmap.  There was, however, a file `~/Library/ 
texmf/fonts/map/dvips/MinionPro/MinionPro.map`, which I removed, and  
then ran i-installer again (just to be sure I'm doing it correctly:   
I chose to configure only, then (after choosing to initialize TeX,  
since it says I've never done so before - see below), I chose "update  
font mappings"; I checked "MinionPro.map" (which was unchecked again,  
despite the fact that I checked it when I ran i-installer last); I  
chose no for full font inclusion; Then finished.)  No luck.  (Was I  
supposed to just remove the debris and re-run i-installer?  Or  
something additional?  Sorry for my lack of the relevant knowledge!)

(By the way, each time I run i-installer, it says I've never  
initialized TeX.   This makes me worry that it doesn't have  
appropriate permissions or something like that...)

I double-checked, and on the working machine, i-installer definitely  
does not mention MinionPro.map in the checklist, when I "update font  
mappings".  How can I find out whether I have different TeX setups  
active?  Perhaps that is the cause of all my problems?  (Recall that  
I do have an old TeX directory on the hard drive, at /usr/local/teTeX.)

I suspect this is irrelevant, but I noticed that my copy of TeXshop  
lists, in the preferences, Engine pane, /usr/local/teTeX/bin/i386- 
apple-darwin-current as the (pdf)tex path setting.  I tried changing  
it to /usr/local/gwTeX/bin/i386-apple-darwin-current, but that had no  


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list