[OS X TeX] problems with Minion Pro package with gwTeX

Ted Sider sider at philosophy.rutgers.edu
Thu May 31 17:56:40 EDT 2007

On May 31, 2007, at 5:41 PM, Bruno Voisin wrote:

> Le 31 mai 07 à 21:29, Peter Dyballa a écrit :
>> Am 31.05.2007 um 20:50 schrieb Ted Sider:
>>> At any rate, I'm still unable to get MinionPro working.  Here is  
>>> some relevant information:
>> Then do it the Mac way: launch i-Installer, make it run in expert  
>> mode, choose the TeX package and then press the "Configure Only"  
>> button. In this process you can choose to alter the use of MAP  
>> file fragments. If your Minion-Pro MAP file fragment can be found  
>> by updmap or updmap-sys, it will appear in the list – could be you  
>> have to allow a private configuration earlier (could be you need  
>> an up-to-date version of i-Installer for this). Select the Minion- 
>> Pro MAP file fragment by clicking the check box and finish the  
>> whole procedure. Then Minion-Pro will be available.
> By default, installing and configuring the TeX i-Package sets  
> texmf.cnf as follows:
> % TEXMFLOCAL contains any local system TeXadmin overrides
> % $VARTEXMF is where texconfig writes its local settings
> [...]
> % teTeX-3.0 and TL2005+ require these. Note, if you want pre-2005  
> behaviour,
> % set GWTEXVAR to VARTEXMF. That makes foo and foo-sys behave the same
> % roughly and close to old-style). Setting GWTEXVAR to HOMETEXMF  
> gives you
> % new (incompatible) behaviour
> If I understood correctly (but I'm walking on eggs here), this  
> makes both updmap and updmap-sys write to /usr/local/gwTeX/ 
> texmf.local, which requires sudo. Accordingly, I think your advice
> 	updmap --enable Map MinionPro.map
> produces nothing (updmap attempting to write to /usr/local/gwTeX/ 
> texmf.local, and failing, because this requires admin rights and  
> hence sudo).
> In order for it to work, you would need to first re-run the  
> Configure stage of the TeX i-package, and at the very last step  
> select "No" when asked whether to make the setup backwards- 
> compatible with pre-2004 versions. This would change in texmf.cnf  
> one line to
> hence allowing updmap to write to ~/Library/texmf and allowing the  
> user to run
> 	updmap --enable Map MinionPro.map
> But really, given the original poster is obviously not at ease with  
> font configuration and just wants things to work, I see no point in  
> directing him towards making his setup non-standard as a  
> prerequisite to solving his problem. Whether you agree with the  
> default settings or not, I think it would serve the OP's interests  
> better to stick to these defaults when helping out, and possibly,  
> when everything is solved and working, point out that there could  
> be others, potentially better, ways of solving the problem.
> Meaning that, in the present case, without changing the  
> configuration of the TeX i-package at all, and with MinionPro.map  
> inside ~/Library/texmf/fonts/map/dvips, the following should work:
> 	sudo updmap-sys --enable Map MinionPro.map
> Beforehand, it would be safer to check for the existence of files:
> ~/Library/texmf/tex/generic/config/language.dat
> ~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm.map
> ~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_dl14.map
> ~/Library/texmf/fonts/map/dvipdfm/updmap/dvipdfm_ndl14.map
> ~/Library/texmf/fonts/map/dvips/updmap/builtin35.map
> ~/Library/texmf/fonts/map/dvips/updmap/download35.map
> ~/Library/texmf/fonts/map/dvips/updmap/ps2pk.map
> ~/Library/texmf/fonts/map/dvips/updmap/psfonts.map
> ~/Library/texmf/fonts/map/dvips/updmap/psfonts_pk.map
> ~/Library/texmf/fonts/map/dvips/updmap/psfonts_t1.map
> ~/Library/texmf/fonts/map/pdftex/updmap/pdftex.map
> ~/Library/texmf/fonts/map/pdftex/updmap/pdftex_dl14.map
> ~/Library/texmf/fonts/map/pdftex/updmap/pdftex_ndl14.map
> ~/Library/texmf/web2c/updmap.cfg
> ~/Library/texmf/web2c/fmtutil.cnf
> ~/Library/texmf/web2c/*.log
> ~/Library/texmf/web2c/*.fmt
> and remove them if they indeed exist; on a default gwTeX install,  
> these files shouldn't be present.
> Bruno

Bruno -

that worked - thanks so much!  none of those files were there; but  
after sudo updmap-sys --enable Map MinionPro.map, the MinionPro  
package worked.  I appreciate the help very much.


------------------------- Helpful Info -------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/
List Reminders & Etiquette: http://www.esm.psu.edu/mac-tex/list/

More information about the MacOSX-TeX mailing list