[OS X TeX] help with Beamer

Richard Koch koch at math.uoregon.edu
Mon Nov 19 00:55:39 EST 2007


On Nov 18, 2007, at 9:24 PM, Linda Lanz wrote:

> Good evening,
> OK, I'm just going to bite the bullet and ask here since I got  
> nowhere with Google for this problem. I'm hoping someone can help me  
> figure out what I'm doing wrong with Beamer. Probably very simple  
> and obvious, but when you can't get something working right, it just  
> gets more and more frustrating. I'm using MacTeX with TeXShop on OS  
> 10.4.10 on both a PowerPC and an Intel laptop. I have no trouble  
> compiling other documents, but I can't get anything using Beamer to  
> work on either machine.
> I followed the Beamer installation instructions included with the  
> package, and I have recent versions of pgf and xcolor as the package  
> requires.

This example typesets fine for me using MacTeX.

You write "I followed the Beamer installation instructions included  
with the package." This could well be the problem, because beamer is  
already in MacTeX. Also MacTeX has very recent versions of pgf and  

 From your log file, I see that you put these Beamer files in ~/ 
Library/texmf, where ~/Library is the Library folder in your home  
directory. Please RENAME the texmf folder and typeset again (renaming  
will cause TeX Live to use its own beamer files.) I predict that  
things will work well.

If this is the only thing you ever put in ~/Library/texmf, then you  
can safely throw away its entire contents of texmf. Otherwise you'll  
need to extract the beamer contents.

TeX Live is a VERY complete TeX distribution, and you rarely need to  
install common TeX files, even when packages suggest it. Moreover, you  
run the risk of installing something older than the current TeX Live,  
and thus not compatible with it. This is particularly true of style  
files about color or graphics.

Dick Koch
koch at math.uoregon.edu

More information about the MacOSX-TeX mailing list