[OS X TeX] help with Beamer

Axel E. Retif axel.retif at mac.com
Mon Nov 19 06:31:37 EST 2007

On  18 Nov, 2007, at 23:55, Richard Koch wrote:

> TeX Live is a VERY complete TeX distribution, and you rarely need  
> to install common TeX files, even when packages suggest it.  
> Moreover, you run the risk of installing something older than the  
> current TeX Live, and thus not compatible with it. This is  
> particularly true of style files about color or graphics.

This is, of course, the sensible thing to do ---but when it comes to  
Till Tantau's packages, I must confess my weakness, not with  
beamer.cls, which I haven't used yet, but with pgf-tikz.

I'm committed to learn Emacs, TeX and pgf-tikz ---so why not all at  
once? So I do the exercises in the pgf Manual in Emacs running TeX  
(not even pdfTeX), and I'm always updating pgf from CVS. Now ---pgf  
is constructed with LaTeX in mind, but with support for TeX and  
ConTeXt, so some bugs might come out more frequently in plain TeX  
than in LaTeX, bugs which I report to the pgf-users mailing list:


and my experience has been that within hours or at most a day or so  
they are corrected.

So, if Linda needs the work done right away, yes ---taking her texmf  
folder out of her Library works; but if she has the time to  
contribute with a bug report to


it would help the further development of the package.



More information about the MacOSX-TeX mailing list