[OS X TeX] Tags, BibTeX, and font question for TeXShop

Michel Valstar Michel.Valstar at imperial.ac.uk
Tue Jul 1 10:29:17 EDT 2008

Hi Raul,

Regarding your second problem, I find that after changing the bib file, I
have to first trash any existing .aux files, then recompile the bib file,
then recompile the .tex file twice. This solves the problem for me. I
suppose you could write a custom script to do all the updates automatically.



On Tue, Jul 1, 2008 at 1:49 PM, R Martinez <rm.tech at mac.com> wrote:

> All,
> I am using LaTeX with TeXShop Version 2.14 on a MacBook Pro and the 2007
> MacTeX distribution. I will appreciate help with the following three issues.
> 1. TeXShop has a Tags menu that displays all the sections, subsections,
> etc. But it does not display the equation tags. Can the equation tags be
> displayed? I would like to see a list of the equation tags, not necessarily
> under the tags menu.
> 2. I'm having a problem with BibTex, which was working fine with TeXShop
> until I added three new references to the BibTeX file. I use BibDesk to
> create and update my .bib file. The typeset preview of my .tex document
> displays everything correctly, including the old references, but it cannot
> find the three new references. TeXShop does not add them to the typeset
> bibliography (which does display the original 9 references) and the
> citations of the three new references in the text display as [?]. I have
> verified that the updated .bib file includes the three new references. The
> .bibl file created by TeXShop contains only the 9 original references.
> 3. I tried to use the mathbb font shown in TeXShop's LaTeX panel, but I get
> an error when I try to typeset. Here's an example:
> $\mathbb{a}$
> The console reads:
> !Undefined control sequence
> <recently read> \mathbb
> I.440 $\mathbb
>                {a}$
> ?
> Incidentally, I tried to select and copy the console's error message shown
> above, but the console does not let me select the text. Why is that?
> Here's the preamble for my document.
> \documentclass[12pt]{article}
> \usepackage{lmodern}    \usepackage[T1]{fontenc}
> \usepackage{amsmath,epsfig,latexsym,bm}
> \usepackage{exscale,relsize}
> \usepackage{tocbibind}
> Can anyone help?
> Thanks in advance.
> Raul Martinez
> -------------------------- Helpful Info --------------------------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
> List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex
> List Archive: http://tug.org/pipermail/macostex-archives/
> Mac-TeX <http://tug.org/pipermail/macostex-archives/Mac-TeX> Website:
> http://www.esm.psu.edu/mac-tex/

Michel Valstar, Research Associate
Department of Computing
Imperial College London
180 Queens' Gate
London SW7 2AZ, U.K.

tel.: +44 20 7594 8225
fax: +44 20 7581 8024
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://email.esm.psu.edu/pipermail/macosx-tex/attachments/20080701/77b37314/attachment.html>

More information about the MacOSX-TeX mailing list