[OS X TeX] latexit issues

dfen2752 at mail.usyd.edu.au dfen2752 at mail.usyd.edu.au
Sat Jun 14 05:58:02 EDT 2008


Sorry about that. Firstly, I'm running the latest version of Latexit
(1.15.0), which I got from the MacTex 2007 distribution (which I'm also
assuming is the latest). I'm running this on Leopard (10.5.3).

Actually, no matter what environment I use, the error occurs. So i've tried
typing in just text (and choosing the text environment), and the
"unexpected error" message shows. This also happens if I type in

I'm pretty sure the Tex files (pdflatex etc.) work, because I do all my
assignments in LaTeX, using the TextMate bundle. And they all compile
properly. On a side note, I highly recommend TextMate for those of you who
code regularly, as well as typeset.

One thing that might be the culprit is that during the installation from
the distribution, I'm not sure if I checked off all the relevant options.
Do you know how I can check?

I've tried going to the temporary folder that Latexit creates, and running
pdflatex on the temporary file from there, and it works. But I still get
an 'unexpected error' message.


Derek Feng (dfen2752 at mail.usyd.edu.au)
Faculty of Science - University of Sydney
Undergraduate Student
Bachelor of Advanced Science (Adv. Mathematics)

On Sat, Jun 14, 2008 at 1:35 PM, David Watson <dewatson at mac.com> wrote:

It would be helpful if you could state the version of LaTeXiT you are
In addition, please state the version of Mac OS X you are using.

At the very least, give a minimal example of what it is you are trying to

For LaTeXiT in particular, you should make sure to choose the proper
e.g. if you are attempting to typeset something in the normal "text" mode,
then by all means, select that tab.
Eqnarray, Display, and Inline are all intended for mathematical equations
in that >exact< mode.

So if you want to typeset $e=mc^2$ choose the proper inline/display tab,
but if you want to typeset "Energy is equal to the mass times the speed of
light squared" then choose 'text'.

On Jun 12, 2008, at 11:37 PM, dfen2752 at mail.usyd.edu.au wrote:

Dear list,

I am having problems with running LaTeXiT. I've been through the archive to
this list, but haven't found a solution.

Opening up Latexit is fine. However, when i try compiling, it comes up with
an 'unexpected error', and nothing in the error log is helpful. There is a
whole bunch of export statements, followed by:

cd /var/folders/xE/xEm5OXIjHROVEkNVZizEOU+++TI/-Tmp-/latexit-1.15.0
/usr/local/texlive/2007/bin/i386-darwin/pdftex -file-line-error
-interaction nonstopmode

--------------- error while processing pdftex ---------------

I have tried reinstalling the program, but the problem remains. I would be
very grateful if anyone could give me some pointers on how to solve this

I'm new to the concept of mailing lists (so if you guys have already
received the email that I sent previously, then please disregard this one)


Derek Feng (dfen2752 at mail.usyd.edu.au)
Faculty of Science - University of Sydney
Undergraduate Student - Bachelor of Advanced Science (Advanced Mathematics)

-------------------------- Helpful Info --------------------------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: http://www.esm.psu.edu/mac-tex/list/
List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex
List Archive: http://tug.org/pipermail/macostex-archives/
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/

This message was sent using IMP, the Internet Messaging Program.

More information about the MacOSX-TeX mailing list