[OS X TeX] TeXShop: Problems with Unicode

Christoph Hoh lists.ch at freenet.de
Fri Mar 14 01:59:44 EDT 2008

Dear all,

I currently have a problem with TeXShop using  Unicode:
I am trying to texify an older tex-file (about 300 pages, document  
written using WinEdt/MikTeX on a Windows machine) with MacTeX-2007/ 
TeXShop. When the document was created the coding "ISO Latin 1" was  
used. So, I opened the tex-file with this coding and then saved it in  
UTF-8 coding (I am routinely using this coding in TeXShop).

I then have changed


in the preamble.

When texifying this document (TeX and Ghostscript) I receive a lot of  
error messages that seem to be due to the inputenc package or the  
utf8 coding, respectively, e.g.

! Package inputenc Error: Keyboard character used is undefined
(inputenc) in inputencoding `utf8'.

l.2064 ...,\textsc{l}-Alanin zu \textsc{l}-Alanin}
, Rheinische Friedrich
! Package inputenc Error: Unicode char \u8:‰tB not set up for use  
with LaTeX.

l.2065 Wilhelms Universit‰t B
onn, Diss., 1991
! Package inputenc Error: Unicode char \u8:‰tB not set up for use  
with LaTeX.

What goes wrong here?
And how can I easily switch to the input lines that are responsible  
for the errors (I can't use pdfsync)?

I read in several list that TeXShop is known to have a general  
problem with Unicode UTF-8. This is why some people are using  
TeXMaker instead. However I don't see any problems with UTF-8 coding  
in TexShop when creating a new document in TeXShop.

Thanks in advance!


More information about the MacOSX-TeX mailing list